Zotero can't find any PDFs whatsoever (Linux)

I'm behind a network proxy at work.

I've modified proxy type to 4 as per this:
https://www.zotero.org/support/kb/connection_error

After every single attempt I get the x sign next to the citation and a "No PDF found" message.

Even using the scihub firefox extension I get nothing.

I can download citations from the web and sync them fine. But no luck grabbing PDFs...
  • edited July 30, 2021
    Can you provide a Debug ID from Zotero for an attempt?
  • I can't generate a debug ID. I got this pop-up message: "An error occurred sending debug output."

    I've copied the report and emailed it to support@zotero.org.
  • edited August 1, 2021
    Your Zotero just can't connect to the internet at all because of something about your networking setup. It should be showing you a warning about that in the toolbar at startup with a link to this page:

    https://www.zotero.org/support/kb/connection_error
  • I had this warning but it disappeared when I updated the proxy settings. Still can't find PDFs.

    I don't have security certificate errors nor security/firewall software installed.
  • We can't tell you more than what's on the linked page. Zotero obviously can connect to the internet on a standard system, so it's something about your network configuration.
  • Does this error mean I have to do the certificate override?


    [JavaScript Error: "The connection was refused when attempting to contact wss://stream.zotero.org/."]

    [JavaScript Error: "WebSocket connection closed: 1006 "]

    version => 5.0.96.2, platform => Linux x86_64, oscpu => Linux x86_64, locale => en-US, appName => Zotero, appVersion => 5.0.96.2, extensions => Zotero LibreOffice Integration (5.0.25.SA.5.0.96.2, extension)
  • Probably not. You're not getting certificate errors — your requests are just timing out. But it's your internet connection, so you (or your IT department, if this is an institutional machine) would be the only one who knows how it's configured.
  • I should note I can't use the sync option either on my institutional computer. I can sync and download pdfs on my windows home machine where there is no proxy. I've already tried the troubleshooting steps of manually adding my institutional user info and proxy address and port while setting proxy type to 1 in the config editor which did not help. My IT dep is useless.

    The 'no connection' error does disappear when I change proxy type from 5 to 4 but zotero desktop is still functionally offline.


    Do you recommend I install the firefox and copy cert8 to my zotero profile? This is the only troubleshooting step I have not tried.
  • I'm afraid this just isn't something we can help with — we don't know anything about your network setup. This has to come from your IT department.

    There's no need to bother with the cert override steps unless you're actually getting a certificate error and/or know that they're intercepting your secure connections. You can check site certificate info in your browser to check the latter.
  • edited 8 days ago
    It works now after manually changing:
    network.proxy.http
    network.proxy.http_port
    network.proxy.ssl
    network.proxy.ssl_port
    network.proxy.type = 1
Sign In or Register to comment.