Unable to start zotero In ubuntu 18.04 (Gtk-WARNING: Theme parsing error)

edited 16 days ago
Hello,
A few days ago I have encountered a problem which makes me unable to start Zotero, I have no idea how it went well but I am able to start it now. And now, the problem is back and the message is like this.

"There was an error starting Zotero.
You can report this problem in the Zotero Forums.
_initDB<@chrome://zotero/content/xpcom/zotero.js:781:12"

I tried to use the startup error report thing, but the debug report is always blank, I can't get any useful information from there. The only thing I have is the message in the terminal. After a few tries, I have these:

JavaScript error: chrome://zotero/content/xpcom/db.js, line 669: Error: Error(s) encountered during statement execution: attempt to write a readonly database [QUERY: REPLACE INTO settings VALUES ('db', 'integrityCheck', 1)] [PARAMS: ] [ERROR: attempt to write a readonly database]"

[unrelated messages removed — D.S.]

In fact, I have tried to load the older library, it worked. I guess it might have some problem to do with the system language changing. But after all it would be difficult to afford losing the works done in a few weeks. So I am seeking for help.
Thank you.
  • No, it's this:
    attempt to write a readonly database
    There's some sort of problem with either the permissions on the file or folder or some security software preventing Zotero from writing to its data directory.
  • After loading my library in the Windows Zotero and change the preference language to English, it actually worked. Yet, I still have no idea what is going on as I never do anything to the zotero itself and the library since it's working normally.
    In my Ubuntu there is no security software or something like that. Still curious about what actually is going on.
  • Meaning in a VM/dual-boot or on another, unrelated computer?

    It's almost certainly something to do with the file permissions — owner or mode — and a VM/dual-boot that shared files could easily contribute to that. Absolutely nothing to do with a language setting.
  • Yes, it is a dual-boot Windows10/Ubuntu 18.04.
    Is there a way to deal with it if it happens again?
  • This is about your system, so you'd have to debug it. It's not a Zotero issue. Obviously if Zotero can't write to the database, it's not going to work.
Sign In or Register to comment.