No application set to open the document "Zotero_Connector-5.0.86.xpi"

Hello All,

I am unable to install the connector plugin for firefox. When I open the download, I get this error popup:

No application set to open the document "Zotero_Connector-5.0.86.xpi"

And then it asks me to manually choose an application. Is anyone able to help walk me through this?

Thank you!
  • edited 7 days ago
    To install it into Firefox, you need to download it from Firefox, which will prompt you to install it. Unless there's a problem with your Firefox installation, you should only get an XPI file on disk if you try to download it from another browser.

    You can still install it manually from the file from the Add-ons pane in Firefox, but that shouldn't be necessary.
Sign In or Register to comment.