Zotero Connector in Chrome cannot get access to PDF files by clicking

I just found Zotero Connector cannot convey PDF files in Elsevier to my Zotero software. I am using the educational network, thus I have the authority. A strange thing is that I can get PDF files in Edge via using the ZC extension. I am wondering what is the problem with my Chrome.
Looking forward to suggestions.
  • Not sure what you mean by "in Elsevier".

    What's a specific URL where you're having trouble?

    What exactly happens?

    Can you provide a Debug ID from the Zotero Connector for attempting to save and not getting a PDF?
  • Elsevier is a website that provides thousands of academic papers.
    URL: https://www.sciencedirect.com/

    Debug ID: 2082288527

    thanks for your time.
  • edited 12 days ago
    No, Elsevier is a company. ScienceDirect is a site. If you’re having a problem on ScienceDirect, you need to say ScienceDirect, and you need to provide a full example URL where you’re having trouble, because there are many different variations of pages on ScienceDirect.

    And that’s a Report ID, not a Debug ID. Please follow my link.

    You also still haven’t explained what exactly is happening.
  • Sorry for the misleading information.
    Debug ID: D160741748

    Normally, when I found desired papers, I just clicked Zotero Connector (ZC) in Chrome, then I can find the paper title associated with the PDF file in my Zotero application (Windows 10).
    However, today I just found the PDF file cannot be downloaded automatically after clicking the ZC button in Chrome. I am sure I can get access to PDF resources. As for the URL, please refer to https://www.sciencedirect.com/science/article/pii/S0010218021002583

    Actually, I cannot download any PDF files if using the ZC extension in Chrome.

    Thanks for your time.
  • are there any solutions for this problem?
  • Just pushed a likely fix. Your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences. Please give it a try and let me know if everything works correctly.

    The solution for this problem was to update and merge in some code contributed by another developer. Considering that it was a fairly complex set of changes to an important translator, a one-day turnaround isn't too shabby!

    Re: "Actually, I cannot download any PDF files if using the ZC extension in Chrome," that sounds like a separate issue. Could you link me to a different site (not ScienceDirect) that doesn't give you PDFs in Chrome but does in Edge?
  • @AbeJellinek, thanks for your help. I tried based on your suggestion, however, it still doesn't work in terms of saving PDF files on ScienceDirect.

    As for ZC in Chrome or Edge, I checked that the ZC in both of them cannot work well right now (i.e., saving PDF files) on ScienceDirect. It is true that ZC did work well on ScienceDirect, as I mentioned above, the day before yesterday in Edge but did not in Chrome. I just noticed a thing that might be related to this problem: the website of ScienceDirect seems updated recently, you can find it from its layout and figures. When I tried to use ZC in Edge, the ScienceDirect has not been updated at that time. In this case, I guess this problem is closely linked to the ScienceDirect website. According to your suggestions, I tried ZC on Springer and ACS Publications, and ZC works well.

    I am wondering if it is a common problem? or I am a single case.

    Zotero is of importance to my research, I am looking forward to solutions. Thank you very much for your very patient help!
  • OK, interesting. Could you give me the URL of a page that you don’t get a PDF for?
  • Sorry for my late reply. ZC connector works well right now and this problem has been fixed. Thank you very much for your time and support.
  • Great! No problem at all. Glad to hear that it's working.
Sign In or Register to comment.