Connector Firefox and Chrome not accessible

I'm running Firefox 89.0.2 and Zotero 5.0.96.2
There are two extensions (Ghostery an ad-blocker and Webex meetings) alongside Zotero. There are two plugins (a codec for Webex and decription module from Google)

When I click on 'save to zotero' the window appears but is minimized at the bottom of the screen. I can see the thumbnail but cannot maximize it or use it in anyway. This has happened for a while. So I used the plugin in Chrome as an alternative.

Chrome has the following extensions enabled: Adobe Acrobat, Cisco Webex Extension, Google Docs Offline, Zotero. For apps: Chrome apps (Docs, Sheets and Slides).

Chrome has now started to behave in the same way as Firefox (a minimized inaccessible window).

This is super tiresome. Please advise on how to test / narrow down the problem and fix.

Thanks!

  • Could you take a screenshot of the problem, upload it somewhere (like dropbox) and post a link to it here? Does disabling other extensions help at all? How about using Firefox with a new profile?
  • Hi
    Here is the link:
    https://stanworth.site/james_stuff/dead_zotero.pdf

    I've tried reinstalling and disabling extensions without any success. It was happening even before Cisco added its extension.

    I've also tried re-building the Firefox profile - but the problem persists.

    Any other thoughts? I would really like to get this going again. Is there a work-around without using this plugin for the short-term?
  • This means by Zotero is half dead . . . :(

    If I am on the journal page then I can click "save to Zotero" and it will save to my library. However, if I'm in Google Scholar and the window to choose references opens then it won't work (since I cannot get the window to to maximize).

    Any new ideas, please? :D

  • This is either a Windows problem or due to something else you have installed. The extension just opens a small browser browser. If Windows isn't showing it open to you, I'm afraid that's something you'll have to debug on your system.
  • Could you give a few pointers about where to start debugging?
    Presumably the browser must be throwing an error that is logged somewhere?
  • This really doesn't have anything to do with Zotero. Again, we're just opening a window in the browser. The problem you're seeing is clearly with window management in your installation of Windows. That's not something we would have any insight into.
  • "This really doesn't have anything to do with Zotero."
    Well by definition is must do becuase it is interfacing with parts of my system.

    "we're just opening a window in the browser."
    So the window is appearing but not fully opening - so will Zotero be throwing an error, my browser or windows?

    "is clearly with window management in your installation of Windows"
    Something obscure presumably is happening here? My installation of Windows 10 is factory and I've not done any customization. Is this window's behavior controlled by Windows or by the Browser?

    If the claim is this is not Zotero then should I be looking for help on Microsoft Windows support site?

    If the window is controlled by the browser then presumably I should go to Firefox?
  • edited 15 days ago
    Well by definition is must do becuase it is interfacing with parts of my system.
    No, you're misunderstanding. The fact that it's the Zotero extension opening a window is completely irrelevant. Anything could be opening a window. This is some bug in Windows or some other app you have installed. No one else has reported it. It's not something we have any way of helping you with.

    If you're saying this happens in both Chrome and Firefox, it wouldn't have anything to do with those browsers either and you should ask Microsoft for help.
  • @101james A good way to debug windows like that in Windows is to right-click the window preview from the start toolbar and select "Move", then use arrow keys on the keyboard to try and move the window. Your mouse cursor will jump to the location on the screen where the window is supposedly being displayed.

    You should test with Firefox and if it works fine there then it's likely a Chrome-Windows bug, although I tried searching for something like this on the Chrome bugtracker and found nothing
  • @101james says it's both Firefox and Chrome, so no reason to think it's a browser bug.
Sign In or Register to comment.