Unable to change Linked Attachment Base Directory

I just install Zotero onto a new laptop, and attempted to update my 'Linked Attachment Base Directory' (Preferences-Advanced-Files and folders-Choose base directory) to "C:\Users\doug_\OneDrive\Personal\Zotero_Library", but when I click on an attachment, it cannot locate it and still uses an old pathway. I believe the problem is that the old pathway refers to an old work computer that I no longer have access to. It is also under a OneDrive directory, but as mentioned is under an account for an employer I no longer work for, so I cannot log in or sync with it. Short of reattaching each attachment individually, is there a way to fix this?
  • Was a base directory set on the previous computer? If so, this should just work.
  • But if @dweihrauch is seeing an absolute path from the old computer, it wasn't set correctly on the old computer (or the computers weren't both synced since it was set). @dweihrauch, if you can recreate the old path on this computer temporarily, you can move your files there, temporarily point the base directory there to convert the files to using relative paths, move the files back, and update the base directory.

    Otherwise, you'd have to use the Zutilo plugin to batch-update the paths.

    (While this definitely works properly when a base directory is set correctly on both computers, people do get this wrong, so we're going to look into whether we can do more to help automatically relink files in this situation.)
  • I am also facing the same issue.

    My setup is-- Added path "....\Onedrive\Zotero_lib" path in 'Linked Attachment Base Directory" and Zotfile preferences-> General settings->Custom Location.
    When I see right click on any article and click show file, it goes to old folder location.
    I tried removing all references, even from unified docs and trash and then synced everything, checked in zotero web library, then added only two articles to start a fresh. Still no success.
Sign In or Register to comment.