My Connector Stopped Downloading PDFs

My Zotero can no longer download PDFs, although it can save the citation information correctly. I have tried reinstalling the connector and updating the translators, to no avail. I am using Mac and Chrome. My Report ID is 953803898. Thank you so much for your help.
  • Is this on any site or specific sites? Do you see a red X in the save popup, or does the PDF just not show up? What if you try to save a PDF directly (e.g., this one)?

    Can you provide a Debug ID (different from a Report ID) for a save attempt that doesn't save the PDF?
  • Thank you for your response! So far I have tried several major journal repositories, including JSTOR, MUSE and Sage. In each case, the connector can save the article information but not the PDF. The PDF just does not show up.

    I can directly save the PDF you link here, but not those from the sites I just mentioned. I logged my save attempt on JSTOR. The debug ID is D1301484426. Also, I forgot to mention that I use some third-party translators for some sites in Chinese, but I haven't modified other translators. These additional translators no longer download the PDFs as well.
  • Is Zotero set to save PDFs in the General pane of the preferences?
  • No, it was not! Thank you and apologies for wasting your time on this. I must have accidentally unchecked the option, and have been thinking it has to do with the connector.
Sign In or Register to comment.