Zotero Integration Error with Word for Mac

Zotero: 5.0.96.2
Word for Mac: 16.49
Plugin: 5.0.36 (April 29, 2021)

It seems the plugin doesn't work for me even from a new document. As I try to add the first citation I get "Zotero Integration Error. Zotero experienced an error updating your document."

I tried updating Zotero, Word and the plugin. I tried restarting and reinstalling. Is this a known issue?

  • edited 15 days ago
    Is this an M1 Mac? Can you provide a Report ID after this occurs?
  • Yes, it's a M1 Mac.

    Report ID: 1045612958

    [JavaScript Error: "The operation couldn't be completed. (OSStatus error -600.) @[getDocument:application.m:85]" {file: "file:///Applications/Zotero.app/Contents/Resources/extensions/zoteroMacWordIntegration@zotero.org/components/zoteroMacWordIntegration.js" line: 410}]

    version => 5.0.96.2, platform => MacIntel, oscpu => Intel Mac OS X 10.16, locale => en-US, appName => Zotero, appVersion => 5.0.96.2, extensions => ZotFile (5.0.16, extension), Zotero LibreOffice Integration (5.0.25.SA.5.0.96.2, extension), Zotero Word for Mac Integration (5.0.36.SA.5.0.96.2, extension)

  • edited 15 days ago
    Does it work if you restart your Mac? Does it work if you force Word to run with Rosetta?
  • Restarting my Mac solved it. :-)
Sign In or Register to comment.