Google Docs request failed

edited 15 days ago
Issue number: D1924636462

I have been working on a document that has >1000 citations. After I hit refresh I got an error message that the refresh was not possible. Automatic refresh is disabled.

I now seem to be blocked. I have tried to access the document from different browsers and different computers and get 429: Google Docs request failed.

I have also tried a new document but it also doesn't work.
  • That's an error message from Google Docs. They will limit Zotero if you try to use it too much at once, or need to update too many citations. It seems like they may have become stricter with the limit recently too. There is nothing you can do but wait and try later.

    We don't really recommend to work on documents of such size with Google Docs. Zotero will struggle with any word processor with so many citations, but online editors like Google Docs are affected by that much more due to their remote nature. Once you are able to access the document with Zotero again (you can check whether it works by trying to open Zotero document preferences) you could try to transfer the Google Doc to Word or LibreOffice.
Sign In or Register to comment.