Suche Zitierstil bzw. Hilfe beim Erstellen

Hallo,

ich versuche mich gerade am Stileditor, treffe aber leider nie die korrekten Parameter (?):

in den Fussnoten folgt zuerst ein "Vgl.":

Beispiel:

³ Vgl. IG Metall (2010), S. 5.
³ Vgl. Lexikon der Nachhaltigkeit, Multistakeholder Initiativen (2015), S. 10.

Literaturverzeichnis:

Johnson, K. & Harig, F. (2017): Fünf Jahre ESUG: Gesetzgeberische Ziele sind erfüllt. Im Blickpunkt: Auswirkungen auf Eigenverwaltung und Insolvenzplan durch das ESUG, in: Deutscher AnwaltSpiegel (11), S. 6-7.
  • Am Besten du lädst auch deinen bisherigen Code auf Pastebin.com hoch und stellst einen Link hier rein und frägst nach konkreten Sachen, die du nicht hinkriegst.
    Dann kann man dir gezielt helfen.
  • Danke für die schnelle Antwort!

    ich habe mich an der Vorlage "Bachelorarbeit" von "Samac et al." orientiert, da einige Sachen schon passen:

    https://pastebin.com/nZZu4dy6

    - Nur würde gerne die Schriftart auf Klein und Grossbuchstaben ändern (aktuell sind es ausschliesslich Grossbuchstaben)

    - dazu würde ich gerne die et al. Regel in der Fusszeile ändern: ab 2 Autoren sollte "et al." erscheinen: wenn ich mit dem jedoch citation Parameter spiele, ergänzt er kein "et al" sondern ein "u.a."

    - vor jedes Fusszeile muss ein "Vgl. ", hier habe ich gar keine Ahnung, wie ich das umsetzen könnte

    - die Ziffern der Fussnoten sollten als exponent dargestellt werden

    - das Datum sollte in Klammern

    vielleicht hast du ein paar kurze Tipps, welche Parameter ich exakt ändern muss.

    Liebe Grüße

    Svenja


  • edited 15 days ago
    Probleme durchnummerienren, dann geht das noch einfacher (bitte retrospektiv machen). ;)

    1. nach <name-part name="family" font-variant="small-caps"/> suchen und die ganze Zeile löschen.

    2a. Zeile 378 hast du die zwei et-al settings. Die erste von 6 auf 3 änderen.
    2b. Eine neue Zeile zw. 20 und 21 einfügen. Dann das hier rein: <term name="et-al">et al.</term>

    3. In Zeile 385 hinzufügen: prefix="vgl. "

    4. Das wird mittels Word geregelt. Also dort umstellen. Hat mit Zotero nichts zu tun.

    5. Das Fussnoten Datum wir in Zeile 388 ausgespuckt. demnach dort die Klammer hinzufuegen mittels prefix, suffix.

    P.S.:
    Stil kann hiermit validiert werden: https://validator.citationstyles.org/
  • @damnation

    Vielen vielen Dank für die extrem schnelle und hilfreiche Info! :) betreibst du dies hier als ehrenamtliche Tätigkeit?

    Setze mich später direkt ran und gebe Feedback

  • Ja, genau. Über die Jahre habe ich hundere von Stile hinzugefügt, ehrenamtlich. :)
  • edited 15 days ago
    Habe die Änderungen eingepflegt. Funktioniert auch fast alles nach einigem gewurschtel :)

    mein Problem ist die Zeile 385:

    habe dort nun

    "group delimiter=" ", prefix="Vgl. "

    stehen.

    < sowie > stehen dort auch. Diese kann ich hier jedoch nicht posten.

    Als Fehler wird mir folgendes angezeigt:

    Line 386: need whitespace between attributes

    Ich habe jedoch zwischen den Attributen ein Whitespace eingebaut, oder nicht?

    LG
  • edited 15 days ago
    Code via <code>asdf</code> eingeben. Sonst sehen wir nix.

    Aber am einfachsten ist ein Gesamtupload auf pastebin fuer uns.
  • https://pastebin.com/6vJ937GK

    habe es noch einmal hochgeladen, danke für das schnelle Feedback!
  • Die Zeile 385 ist nicht korrekt, weil da ein Komma frei zwischen dem Delimiter und Praefix steht.

    (Ausserdem hast du dort 2 Gruppen, die genau das gleiche machen. Du koenntest einfach eine davon rausnehmen.)
  • Habe die Zeile 385 angepasst. Nun habe ich den nächsten Fehler und verzweifle D;

    Bad value “(issued-year)” for attribute “macro” on element “text” from namespace “http://purl.org/net/xbiblio/csl”.

    <text macro="(issued-year)"/>
  • edited 15 days ago
    Du rufst ein Makro auf, das nicht existiert. Wenn du die Klammern angezeigt haben willst, dann musst du die per Praefix/Suffix einfuegen.
  • habe mal ein wenig rumgespielt und nun keinen fehler mehr, vielen dank. habe auch einiges gelernt!

    der code dort sieht nun so aus:

    <text macro="issued-year" suffix=")" prefix="("/>
Sign In or Register to comment.