problem with data directory and file permissions after data transfer to new computer

edited 19 days ago
Hi,

I've read through a lot of the discussions to try to figure this issue out, but I saw that we should post a new discussion rather than add our question to a thread that might not be the right one!

I have standalone Zotero 5 on a mac.

The data from my old harddrive was transferred to a new computer (both macs) a few years ago - everything worked/works fine except for Zotero. I can open it and see my files, I can add new files, but it quits unexpectedly after a few minutes, and I can't modify any old files without manually changing the permissions on the files (see explanation below). For all of these reasons, I stopped using it, but I need to start using it again and so would like to get this issue solved!

There may be multiple issues, but it seems that one of the main problems is that I no longer have read & write permission for the files that transferred over. For the transferred folders and the files saved within them (within the data directory), it now says that I have 'custom access'. If I change my access to 'read & write' for each file (e.g., if I'm trying to modify it or delete it, etc.), then it works, but it's not feasible logistically to do that for each file, and I imagine there's a better solution.

This issue seems to be causing a number of related problems. For example, currently, it won't let me sync zotero because I tried deleting files in the zotero trash but I don't have permission for those files so in order to delete them I need to find them manually within the data directory and change the permissions. That gets rid of the error message for each file one by one, but again I don't have time to change the permissions for each file and, again, I bet there is a better way!
e.g., I get this error message when I try to sync, and it refers to files that are in the trash, which I tried to empty:

"The file '/Users/allisonkendra/Library/Application Support/Zotero/Profiles/e3fv52ee.default/zotero/storage/AWUAS4V4/.zotero-ft-cache' cannot be deleted.

Check that the file is not currently in use and that its permissions allow write access.

Restarting your computer or disabling security software may also help."

I have Zotero 5 but my Data Directory Location is custom (the person who transferred my harddrive data over for me may have done that, or it may have been like that already - I'm not sure) and looks more like what is listed for Zotero 4 (2017 and earlier), i.e.,
/Users/<username>/Library/Application Support/Zotero/Profiles/<randomstring>/zotero
(from https://www.zotero.org/support/zotero_data)

Can some of these problems be fixed by using the 'Migrate To New Default Location' button or setting the Location to Default instead of Custom?

Other pieces of information about how my zotero's operating that may or may not be useful:
-- Every time I open zotero, it opens to the same folder (perhaps the last one I had open before the data transfer?). It is a subfolder within a subfolder within 'My Library'.
-- If it doesn't unexpectedly close on its own (which as I said, usually happens if I try to do anything within zotero), and I try to quit zotero, it takes it a long time to close (when I right click it afterwards it says 'Application Not Responding' and gives me the option to force quit). It does finally close but then it gives me the same message I get when it quits on its own, i.e., 'Zotero quit unexpectedly'

And three things that I think are newer circumstances (perhaps since some more recent Zotero updates)
-- When I open it now, every time it says 'Installing Zotero Word for Mac Integration'
-- And then gives me an error that says 'Zotero was unable to load translators and styles.'
--And if I have Word open when I open Zotero, then it also says 'The Zotero Word plugin has been successfully installed, but Word must be restarted before it can be used.' (I have restarted Word many times after receiving this message - it only shows up when Word is open at the same time.)

Please let me know if you have any recommendations about how to make my Zotero more functional again. I understand that these all may be related or separate issues! Happy to provide any more info. Thank you for your help!


  • edited 19 days ago
    All you need to do is give your current user account read and write permissions to the copied data directory and all files under it. You can do that in one step from File → Get Info. You'll need to click the lock icon to make changes. You certainly don't need to do it individually by file.

    If for some reason you can't get it to work that way, we can give you a Terminal command to run, but that shouldn't be necessary (and this would really be getting into general macOS troubleshooting, not a Zotero problem).
    I have Zotero 5 but my Data Directory Location is custom […] and looks more like what is listed for Zotero 4
    OK, you should change that at the same time. Close Zotero and move the 'zotero' folder to the root of your home directory, and capitalize the Z, so that it's /Users/:username:/Zotero, with zotero.sqlite directly within that.
  • @allisonkendra: Actually, they may have copied the entire Zotero profile directory as well, so you'll also need to fix permissions on /Users/:username:/Library/Application Support/Zotero. Without that, Zotero won't be able to save any settings.
  • (And for future reference, transferring data to a new Mac should always be done with Migration Assistant, which will do a seamless transfer of all data without these sorts of permissions problems. Again, this isn't a Zotero problem at all — Zotero just can't write to its own files, and there's absolutely nothing it can do about that.)
  • Thanks so much for your help @dstillman. It was a professional IT person at my university who transferred the data (not that they can't still make errors), using Migration Assistant, and somehow it is only my Zotero folder that has a problem. But I understand that this is not a problem with Zotero, but rather a problem with the data transfer and mac. I asked for help from IT, but they were not able to resolve my zotero issues, hence my asking here! If it would be better to go back to IT based on what I say here, please let me know and I will try that instead. Thanks again for your help and advice.

    I made all of the changes you suggested, but the issue within Zotero is the same. For the emptying the trash/syncing issue, I can only get the error message for specific files to go away by deleting the individual storage folder associated with the error (I thought that changing permissions for the file worked, because it has previously allowed me to edit files that way, but it seems it doesn't work for this particular error). Here's some more info on what might be happening with the permissions:

    As compared to the other folders in my computer, only my Zotero folder shows a username as 'Fetching' and says 'You have custom access'. I changed the permissions for the folders with 'Get Info', and though all of the users are now listed as 'Read & Write', it still shows a Fetching user (with Read & Write permissions now, as with all of the other users listed), and says 'You have custom access'. This is the only difference that I can see between my Zotero folders and the other folders and files in my computer regarding sharing and permissions.

    When I look at 'Get Info' for the files within each of the storage folders (after having made these changes), there is now a new 'everyone' user listed that the top that says its access is 'Custom', and it still reads 'You have custom access'.

    For the file that is currently giving me the error I first posted above, I changed the new 'everyone' user to have 'Read & Write' access (instead of 'Custom') but the error message is the same.

    I also did this:
    "OK, you should change that at the same time. Close Zotero and move the 'zotero' folder to the root of your home directory, and capitalize the Z, so that it's /Users/:username:/Zotero, with zotero.sqlite directly within that."

    So now the error message says the same thing but reflects the new position of the folder:
    'The file '/Users/allisonkendra/Zotero/storage/AWUAS4V4/.zotero-ft-cache' cannot be deleted.'
  • As compared to the other folders in my computer, only my Zotero folder shows a username as 'Fetching' and says 'You have custom access'
    Yes, this is (clearly) not a Zotero problem, so it's really not something we can get into here — any competent IT department should be able to resolve this easily. Once you've fixed the permissions on both your Zotero data directory and profile directory, Zotero will work normally.

    I really can't spend much time on this, but if you open up Terminal (via Spotlight), run the following command, and copy the output here, we might be able to give you a quick solution:

    ls -la ~/Zotero ~/Library/Application\ Support/Zotero ~/Library/Application\ Support/Zotero/Profiles ~/Library/Application\ Support/Zotero/Profiles/*

Sign In or Register to comment.