Zotero cannot capture a particular item by DOI

Hello,

I'm trying to add an item to my library but Zotero cannot recognize it. Here's the item: https://doi.org/10.5604/01.3001.0013.5929. The PDF is available in the URL and can be accessed by anyone for free.

I tried three methods, all failing:
1. In Zotero desktop, use "Add Item(s) by Identifier". Result: lookup failed.
2. Open the item's URL in Firefox, then use Zotero's Firefox extension. Result: the URL is captured as a web page rather than an article.
3. In Zotero Web Library, use "Add By Identifier". Result: identical to the result in method (2).

I followed the debug logging process and the Debug ID is D2053550711, if that matters.

I'm not sure what else can be done
  • Hello,

    I tried adding this item with "Add Item(s) by Identifier" in the latest macOS beta build, version 5.0.97.

    Is this issue caused by a Zotero bug and if so, can we expect it to be fixed in upcoming builds?

    Thanks in advance.
  • edited 6 days ago
    Unfortunately no data is available for that DOI using the standard method we use, which works for most DOIs.

    @adamsmith, do we know why metadata would be available via the API but not via content negotiation? Particularly since, if I'm reading this right, the RA here is Crossref?
Sign In or Register to comment.