What does this error message mean?

Error parsing webpage 1, got error: InvalidStateError: responseText is only available if responseType is '' or 'document'.

When I try to transfer an article with zotero connector (usually science direct) I get this error. This error occurred after playing with the engines.json file.
  • Where exactly are you seeing that? See both parts here:

  • edited June 2, 2021
    error id 447934735

    I pressed the button in my browser to transfer the article with zotero connector. then getting error while downloading pdf. probably during the snapshoot.
  • You'll also need to provide more details about what you're actually doing when the error occurs, i.e. the "Steps to reproduce" part.
  • @zmetedinler: It's still not clear where you're seeing an error or what the actual problem is that you're reporting.

    If it helps, you can take a screenshot, upload it somewhere (e.g., Dropbox or Google Drive), and provide a link here.
  • 1. I pressed zotero connector. Worked
    He read the article title that should have been. zoteroda file generated
    2.) pdf uploaded to zotero.
    3. snapshhot should be installed. but not loaded. gave an error message.
    4. I didn't do anything else. and I just waited during the processes.
  • Can you provide some screenshots? I still don't understand where you're seeing an error message.

    We'll also need an example URL of where you've having trouble.
  • So how can I send this screenshot to you?
  • edited June 2, 2021
    @dstillman I send to gdrive.
  • I explained how to provide screenshots above.

    You can also email them to support@zotero.org, but you'll get faster support if you link to them here, so email should generally only be used when you have something you can't share publicly.
  • edited June 2, 2021
    That "Error parsing webpage" error is likely from some plugin you have installed. Disable all your plugins, and if that fixes it, re-enable them one by one until the problems recurs.

    That ScienceDirect page saves for me. Try resetting translators from the Advanced → Files and Folders pane of the Zotero preferences and then from the Advanced pane of the Zotero Connector preferences (via right-click on the save button). If that doesn't help, try disabling all your Zotero plugins.
  • Oh, but we also don't support Opera. You should test in a supported browser such as Firefox or Chrome.

  • I sincerely thank you for your patience and interest in me.
    Sometimes I really want my English to be better. today is one of those days. I had a hard time expressing myself. Sorry.
  • Opera runs chrome extensions very well. I've also been using it since version 2 of opera. There are moments when I don't know what to do.
  • You're always welcome to post in your native language if that's easier, even if we'll respond in English. And you can always link to a screenshot to more clearly show what you're describing.
    Opera runs chrome extensions very well.
    Yes, but we don't support it, so when you encounter a problem and want help here, you need to first reproduce the problem in a browser we do support.
Sign In or Register to comment.