Cannot create a bibliography

I am writing a document. a month ago I had a full biblio at the end. Today I notice that it is gone and I cannot create a new. I clicked Add/Edit Bibliography I got this message:

Zotero experienced an error updating your document.

An error occurred communicating with Zotero:
java.lang.ClassCastException: class cannot be cast to class java.lang.String ( is in unnamed module of loader @4517d9a3; java.lang.String is in module java.base of loader 'bootstrap')
at java.base/

Please anyone give a suggestion. I am using ver 5.0.54.
  • If you really mean Zotero 5.0.54, you'll need to upgrade to a current version before we can help you, as well as a current version of LibreOffice. 5.0.54 is from 2018.
  • @skaeoman You should certainly update both Zotero and LibreOffice, but this is a bug in LibreOffice that we have known of for a while and LibreOffice has not fixed

    Using "Next style" property for LibreOffice styles will cause issues with Zotero.
  • I tried updating Zotero, what I got is:
    sudo apt-get install zotero-standalone
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    zotero-standalone is already the newest version (5.0.54-ubuntu1).

    I have updated LibreOffice.

    I am using Ubuntu 20.04, is this the limitation?
  • That's some unofficial, unmaintained package.
  • Thank you I am trying to update Zotero.
    For now, I start a new document and the bibliography works well. So something is wrong with the setting of that particular file of mine.
    Where could the setting be?
  • You can see Troubleshooting Errors in Word Processor Documents, but you really need to update Zotero. We can't help you further here while you're on an outdated version.
  • @skaeoman I have already told you what the issue is. One of your styles, most likely a Footnote or Bibliography style has a custom "Next style" property set in LibreOffice. You need to remove that.
  • Thanks for your suggestions. Let me try that and will inform you soon.

  • I successfully got zotero
  • I have got Libre 7.1 writer.
    Will try what you suggested.
  • Now I have 2 LibreWriter (1) Ver (2) and Zotero
    Both writers cannot create my bibliography in the mentioned document.

    As by 'Troubleshooting Errors in Word Processor Documents,I have tried deleting a part and tried creating the biblio, undoed and deleted the others but did not succeed.
    I might re-cite every citations in hope to undo the broken one(s).

    I checked the page style and it was the same with other sections. Usually I start a new section with "Right page' style, the next is 'Left page'. Same with paragraph styles, nothing unusual.

    A new problem, in Writer ver, I cannot add the Zotero buttons.
  • Unless I'm misunderstanding what you changed, this still applies:
    Using "Next style" property for LibreOffice styles will cause issues with Zotero.
    I don't know if this is unusual or not, but it's a known issue due to an upstream bug, linked above.
  • I have it back.
    It is the style. But I have to go to menu of 'Insert>Table of Contents and Index>Table of Contents, Index or Bibliography>Bibliography>Style' and edit the style inside this pane, not the paragraph where I want to place the biblio in my document. In the old document I might have changed the setting in the pane unintentionally.
    The 'usual' I mentioned above is about the paragraph styles I use in both of my documents, they are the same as I usually set them.
    Thanks for your suggestions.
Sign In or Register to comment.