DOI saved as full URL in the DOI field

Until recently DOIs have been saved as the DOI only in the DOI field, like this:


Lately this behaviour has changed on some pages to include a full URL including, see e.g. what happens when 'Save to Zotero' this page:

If the URL is to be saved, it should go in the URL field. The point of DOI is to outlast things like HTTPS, so that when protocols change in the future we don't have to update all the DOI fields.

The DOI handbook says that:

"The DOI name has two components, the prefix and the suffix, which together form the DOI name, separated by the "/" character. The portion following the "/" separator character, the suffix, may be an existing identifier, or any unique string chosen by the registrant. The portion preceding the "/" character (the prefix) denotes a unique naming authority. There is no limitation on the length of a DOI name."

The behaviour is inconsistent - PubMed entries' DOIs are still saved as just the DOI, it seems to be limited to publishers' sites where DOIs are displayed in URLs. Maybe a translator issue?
  • yeah, that's not intentional -- they've likely just added the https resolver to the DOI in the metadata at Wiley
    Issue created here:
  • @mdoube: Fixed (in the Wiley translator). Thanks for reporting this. Your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences.
  • A similar issue exists with Wiley and a few other publishers when importing nbib from PubMed.
  • Could you provide an example? I'll take a look.
  • @AbeJellinek Please accept my sincere apology. My nbib comment was based upon faulty memory. I reviewed the last 5 days of my PubMed nbib imports and didn't find an example of the full URL in DOI problem with Zotero.

    I am aware of other publishers' metadata that does present the DOI as a full URL. I'll provide examples later today.
  • @DWL-SDCA Great! Not a problem. I'm always happy to hear that there *isn't* a bug.

    Please do let me know about those other cases.
Sign In or Register to comment.