Modifying a citation broke the document

edited May 27, 2021
I have 4/5 "long" citations (7/8 papers each).

I modified one of them to insert another paper.

After modifying it Zotero arbitrarily changed the font size of that citation back to 12 (it was 9) against my will. Ok, no big deal.

Then I went to a second citation and clicked on "Edit with Zotero" to modify it and insert another paper.

Now Zotero is saying that my document is broken. Here is the error message:

How can I proceed?

I am using Google Docs, latest Zotero app for Linux (Fedora 34 Workstation)
  • edited May 27, 2021
    After closing Chrome and Zotero and re-opening them, now clicking on "Edit With Zotero" does nothing

  • Same result with both Google Chrome and Firefox. Clicking on "Edit with Zotero" does nothing.

    I have tried the File -> Create copy suggestion in the troubleshooting.

    In the copy of the document, "Edit with Zotero" on that citation return

    "selectedFieldID is null"

    Can you please explain what is happening and how can I repair my document?
  • Could you submit a Report ID from Zotero? Does it work if you use the Add/Edit citation option from the Zotero menu instead of clicking on Edit with Zotero?
  • Report ID should be 773546185

    I temporarily fixed it by removing the citation and writing it again
  • If you can figure out what steps caused the error and reproduce it from scratch we'll try to fix it.
  • Is the debug log better if I enable "Debug Output Logging"?

    I don't know how to reproduce it and don't have much time for trying
  • I have shared a document snippet to your email address
Sign In or Register to comment.