OOo Firefox Add On 3.0a3

I've recently updated the OOo Firefox addon, and it's behaving very oddly. When I open Firefox, it shows the "Installing Zotero OpenOffice Integration" window for a while (5-10secs) then loads Firefox. Not a show-stopper, but quite annoying as it does it whenever a new Firefox window is opened (whether it's already running or not.)

Also, if I open the Add Ons window and choose options for the OOo addon, it gives me the same Installing window, then crashes Firefox.

All the citation inserting etc. still seems to work fine though!

I'm using Firefox 3.5.3, Zotero 2.0b7.2, OOo Addon 3.0a3, Word Addon 3.0a2 on Windows Vista.

Any suggestions please?
  • Can you provide a report ID (assuming there's something to be reported there)?
  • I've posted a report - D791562552. This is when I open up Firefox as usual, and get the initialising window. This is actually a different computer, but the same problem with the same software (Firefox 3.5.3, Zotero 2.0b7.2, OOo Addon 3.0a3, Word Addon 3.0a2 on Windows Vista).

  • I've also submitted a second report - D801352900. This is when I open up the OOo Addon options, and it just hangs with the initialising window. I can't use the addon window, but can use Firefox as usual. When I 'End Progress' (through Task Manager) on the initialising window, it closes and opens the addons options window. It shows this for about 5-10 sec, then closes down the whole of Firefox.

    I hope this helps. Let me know if there's anything else I can do.

    Thanks for your help,
  • I was actually looking for an error report ID, not a debug ID; you can get this by selecting "Report Errors" from the cog menu.
  • I'm afraid it doesn't actually generate an error, so the option is greyed out. Is there anything I can do to create one, or what's the next step?
  • I have a very similar problem. Program and Addon versions are the same except I'm running Windows XP. Also, instead of crashing firefox when pressing the options button in the firefox addons window a progress window opens saying "installing Zotero OpenOffice Integration..." This will only stop after I use task manager to end all firefox processes. I can add citations and bibliographies to documents fine. I submitted an error report (1410711126).
  • bry
    edited September 24, 2009
    I'm getting something similar on XP. It seems to relate to Firefox beginning, but not ending, a Java process, as the Java icon appears in my system tray and won't go away, even after the extensions (Zotero and the OpenOffice integration) have supposedly updated and Firefox has been closed. Then next time you try and start firefox you can't, because one is still running. This problem can be addressed by ending the Firefox process in the Task Manager, but it doesn't go away, at least not yet. To break the cycle I had to uninstall the Openoffice extension, end the Firefox process again to get rid of that pesky Java icon, and then reinstall the extension.
  • edited September 24, 2009
    I can confirm the same bug with Ooo- zotero integration firefox add-on. The progress window just stalls when I press add-on options from firefox, displaying "Installing Zotero OpenOffice integration" message. I have cleared uninstalled the extension from both FF and OOo, cleareed the residual folders in the FF profile folder and in OOo uno packages cache, and then reinstalled; however, whenever I start firefox the same progress window (Installing Zotero OpenOffice integration) reappears.
  • Can a couple of you give the OpenOffice trunk XPI a try? It may or may not fix the problem, but if it doesn't, and if you can report back what the progress window says during the crash, it might help me track down exactly what's wrong. Note that you'll have to manually install the next release version when it becomes available.
  • ok, now the trunk works - the options dialog in ff addon correctly displays the "integration preferences" dialogue, and the OOo plugin also works following a restart of both firefox and openoffice.

    Thanks for the help.
  • Well, I am sorry I think I decided too early: after restarting my pc, the progress windows appears again whenever I start firefox, indicating that zotero is uninstalling old ooo integration extension and installing the new one. In other words, I can confirm this:

    I am using windows xp sp3, firefox 3.5.3, Openoffice 3.1.1, and Zotero openoffice integration 3.0a1.r5228
  • I tried the trunk version, and everything seems to be working fine for me - thanks!

    How do I know when the new release comes out - I'm guessing I won't get the usual upgrade message from Firefox.

    Thanks for all your help.
  • I've had the same problem with the new OO firefox addon/plugin.
    I now installed the trunk version where the hanging window hasn't appeared so far.
    but when I open my document that I last used with zotero 2.0 beta and the old OO wordprocessor for zotero 2.0beta it wants me to convert my document, but fails to do so with the following error msg:
  • tricipitinus, if you don't mind, can you send your file to with a link to this post?
  • I already solved the problem by manually deleting the inserted bibliography. after that I could transfomr the document and insert the bibliography again.
  • As noted elsewhere, I too have struggled with the integration plug-in under Ubuntu.
    I have taken the suggestion and installed the trunk version. This installs without complaint or crash, and installed when OO was NOT running.

    But, in OO (3.1.1) there is no toolbar visible nor available from the View Toolbar options.

    Thanks for all your help.
  • edited September 28, 2009
    SalishSea, you might want to try starting Firefox from the command line, then triggering "Reinstall Components." If there is an error installing the oxt into, a message should appear there. Note that, on some OOo builds, the toolbar is named "Add-on 1" for some odd reason.
  • Integration relase 5240 has solved whatever issues remained. Toolbar visible, communication with FF, yeah yeah yah!

    Many thanks!

  • Finally got the opportunity to try the OpenOffice trunk xpi. Everything seems to be working as expected.


Sign In or Register to comment.