Suppress author issue with a comma

Hi everyone,

I have a problem with the function of Zotero to suppress the author.
In the end the citation should look like this: blablabla Author (Year).
The problem is that if I tick the option supress author I get: blablabla Author (, Year). How do I get rid of the comma?
I am using the DIN 1505-2 (author-date, Deutsch) - standard superseded by ISO-690 citation style, that I slightly improved to show et al. instead of u. a.

Thanks in advance!
Sign In or Register to comment.