OpenOffice Integration 3.0a2 freezes / crashes Firefox

When trying to cite on my OpenOffice, "the word processor plugin (1.0b4) is incompatible with the currently installed version of the Zotero Firefox extention (2.0b7.1)", so i proceeded with the instructions on "word processor plugin installation". Installed
OpenOffice & NeoOffice "The latest version of the OpenOffice plugin for Zotero 2.0 is 3.0a2. Install the OpenOffice Plugin (Firefox extension, 1.1MB)

and it didnt install just freezed (ive restarted computer and same).

The Error Report just says this



I dont know what any of it means. Any possible help, would be greatly appreciated, am an computer illiterate History student, with imporant notes on my zotero.

thanks in advance to this network of solidarity.
  • Theres also an
    Error Signature
    szAppName: firefox.exe szAppVer : szModName : hungapp
    szModVer : offset : 00000000
  • Well, you can get Firefox to stop freezing by deleting extensions/ from your Firefox profile directory, but this won't make the OpenOffice plug-in work. What version of OpenOffice do you have installed? (You can find out in Help->About in OpenOffice.)
  • OpenOffice 3.0.0

    Deleting it worked, im very pleased, and full of gratitude, you've just saved my past 5 months notes, endless hours, for my Phd!
  • Well, deleting that folder will make Firefox work again, but you still won't be able to insert Zotero citations from OpenOffice until we fix your freeze; the solution I posted above was just to delete the plug-in that works with OpenOffice. I'm not sure why you were getting freezes before (although I'm going to do my best to track the problem down), but it's quite possible that you can get Zotero and OpenOffice to play nicely by downloading the latest version of OpenOffice (3.1.1, I believe) from and then re-installing the plug-in.
  • Updating OpenOffice to 3.1.1 worked.
    When opening older documents that had Zotero Citations, an Error message came up "Your document needs to be permanently upgraded, make a back up".
    But I opened a new WordFile, Deleted the Bibliography, and then i could insert new citacions (after clicking ok on some Error msg), and create a new bibliography.

    thanks very much Cheers
  • It's not an error message; it's a warning. You should make a copy of your file (in case things don't work), and then you can press "OK" when the dialog comes up and things should work.
  • Provisionally, hopefully not transitionally, everything is working now.
    Thank again Simon
    yours truly
Sign In or Register to comment.