Add "Edit with Zotero" to Firefox Google Docs

edited May 12, 2021
In Google Chrome, Google Docs shows a "Edit with Zotero" box below citations. In this way I can understand what is a citation and what isn't.

The Firefox Connector doesn't seem to have this option. The citations have no "Edit with Zotero" box.

Can we add one?

It makes a lot easier to understand what is a citation.

It would be a useful addition and make the connectors comparable with each other :)
  • If you're not seeing "Edit with Zotero", it's not an active citation. That's a standard feature of Zotero's Google Docs integration and is the same in all browsers.
  • Yes I see it now. I don't know what was happening then.

  • Hello,

    Firefox sometimes get "stuck". When the cursor is over a citation, it DOES NOT display the "edit citation" pop up. Then after some time it recovers and siaply the pop up.

    It just freezes for some time and then start to work again.

    I don't know whether it is normal or it is the connector?
  • This is the first time we hear about something like this, so it is likely related to your system and extension setup.
  • I confirm that the Firefox connector takes a lot of time to display the "Edit with Zotero" popup.

    Related to my system or my setup is not a solution.

    We need debug, we need logs, I think

  • You can debug this by disabling other extensions in Firefox, trying a new Firefox profile or trying a different browser like Chrome or Edge. Logs won't show us much in this case.
  • In Chrome it works and the "Edit with Zotero" message box is shown.

    In Firefox the "Edit with Zotero" pop up is not shown when a new in-line citation is added and I move the cursor onto that citation.

    Only after A LOT of time passes, when I move the cursor on the citation the "Edit with Zotero" is finally shown.

    I have tried with a private window with only the Zotero extension enabled, same result. So should be not other extension interfering. I have a private window with _only_ the Zotero extension.

    Can someone else tries if it works for them?
  • in Firefox, if I refresh the page it works and the "Edit with Zotero" pop up is shown.

    It's only when I add a new citation, the "Edit with Zotero" pop up is not immediately shown.

    Can someone else try?
  • I found out that switching windows will have Firefox display the "Edit with Zotero" pop up again. It's probably a bug of Firefox with Wayland
Sign In or Register to comment.