wrong font size in LibreOffice citations after accented letters

I have been writing a text on 11pt font size, which is my standard text body font size and usually Zotero citations are inserted in the standard text body font size. However, strangely, when author names contain accented letters, such as "à", the font size increases to 12pt, from and including this letter to the end of the citation field. I have a screenshot, I don't know how I can add it here.
  • edited 12 days ago
    What word processor and version? What operating system? You can upload your screen shot to any cloud storage service that allows public access, (Dropbox, Google Drive, etc.) and paste a link here.

    I've had this happen with an older version of LibreOffice when pasting text with 'decorated' characters or some ligature combination-characters. In my case, when this happened, I wasn't using Zotero. I think that this had to do with an unorthodox character encoding from the source document and LO not knowing how to compensate for the peculiarities.

    edit - I haven't encountered this problem with newer versions of LO nor with Zotero.
  • Also what typeface/font are you using? Are the accented characters in the same font as the others?
  • @Olib170 You should make sure that you modify the font size in the default document style instead of manually in the paragraph. Zotero inserts text that has accents differently than one without it due to technical reasons and the former is more likely to have issues restoring an in-line style.
  • @DWL-SDCA Sorry, I'm using Libreoffice Version: 7.0.5.2 (x64)
    Build ID: 64390860c6cd0aca4beafafcfd84613dd9dfb63a
    CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
    Locale: fr-FR (fr_FR); Langue IHM : fr-FR
    Calc: threaded

    @bwiernik standard typeface

    @adomasven You got me there, I had thought that I had changed the body text style to 11pt from the standard 12pt. But when I just now verified, then the style itself was still in 12pt. And Zotero uses this, rather than the paragraph format. Problem solved. Thanks
Sign In or Register to comment.