Umlauts and diacritics prevent RTF Scan and ODF Scan from working on Macs

About one year ago I complained here in the forum about that scanning Rich Text Files in Zotero for Mac fails if they contain an umlaut and/or a diacritic.

This virtually blocks all references in other languages than English. Most if not all European languages require umlauts and diacritics of some sort or another.

• I have installed the RTF citation style from zotero.org/styles, but that doesn't help.
• I also installed and tried the RTF/ODF-Scan for Zotero Add-on, but that's even worse. With ODF Scan (from the Tools menu) I always get the message: "There was an error processing this file."

=> Tested with the current Mac version of Scrivener v3.2.1.
=> Tested with the current version of Nisus Writer Pro 3.2.1
=> Tested with TextEdit

Any hope that this will ever be fixed?
Anna

Latest Zotero version 5.0.96.2
MacBook Pro mid 2010
macOS High Sierra
  • Just tested this with LibreOffice for Mac, both RTF Scan and ODF Scan.
    No difference from other applications already tested. Sad. :–(

    Anna
  • The Umlaut issue with RTF scan is I think known (RTF hasn't seen any maintenance for ~10 years), but ODF scan doesn't actually care about the title of an item at all, so something else is going on there. Are you saying you can reproduce getting an error with a simple .odt document from LibreOffice?
  • adamsmith asked:
    "Are you saying you can reproduce getting an error with a simple .odt document from LibreOffice?"

    Yes exactly.

    Below is a step-by-step description of the actions taken.

    1. New text document in LibreOffice created
    2. Select a reference with an umlaut or diacritic in Zotero
    3. From the Edit menu in Zotero execute the "Copy Citation" menu command
    4. Paste the temporary citation into the LibreOffice text document
    5. Repeat once or twice so that I have at least two or three temporary citations with umlauts and diacritics in the LibreOffice document
    6. Save the LibreOffice document to the Desktop. File type: ODF Text Document (.odt)
    7. Close the LibreOffice document
    8. In Zotero, execute the ODF Scan command from the Tools menu
    9. In the upcoming dialog the default File Type "ODF (to citations)" is enabled. As next, I select the input and output files. The input file is the LibreOffice document I inserted the temporary citations into.
    10. When I now click on the button called "Continue", an error message in red color appears below the Input File. The error message reads: "There was an error processing this file"
    11. And the output file name (which was created in step 9) has been removed from the 'output file field' and replaced by the words "No file selected."
  • That sounds like you might be trying to parse RTF scan markers with ODF scan. Here's how an ODF scan citation marker should look like:
    { | Smith, (2012) | | |zu:2433:WQVBH98K}

    Is that what you're inserting?
  • You may be right with your assumption because the temporary citations I have used until now look like this:

    {Árnason, "Íslenzkar þjóðsögur og ævintýri", 1862}
    and
    {Jan Müller, "Nýnorsk. Ýmsir kaflar", 2020}

    How can I get an ODF scan citation marker to look like this?
    { | Smith, (2012) | | |zu:2433:WQVBH98K}

    Am I perhaps supposed to change my RTF temporary citations manually *after* the document has been saved as .odt and *before* the ODF Scan is performed?

    Under the heading "Inserting Citation Markers" on this site we can read:
    "To generate citation markers in Zotero, first set the "Default Output Format for Quick Copy to "Scannable Cite" in the Export tab of the Zotero Preferences."

    Now the problem is, there is NO option with the name "Scannable Cite"in the popup menu "Default Format" in the Export tab of the Zotero Preferences!
  • edited 7 days ago
    Right, you're not getting the ODF scan marker and without that, ODF scan doesn't do anything. It doesn't try to parse RTF-scan-type citations. (It should fall more elegantly, but it's likely failing because there's no valid citation marker in there)

    I believe the install of the ScannableCite generator ("translator") is currently broken for the add-on. Here's how to install that:
    https://forums.zotero.org/discussion/comment/347606/#Comment_347606

    (And since I think you're asking that: there's no way to convert the two formats, so you'll have to manually re-insert the ODF-scan markers, I'm afraid)
  • Thank you for the link, adamsmith. I installed the ScannableCite generator ("translator").

    Tell me if the following procedure is correct:

    1) In order to get the ODF scan marker the Default Format in Zotero Preferences > Export needs to be Scannable Cite.

    2) Temporary citations with ODF scan markers are inserted into my document either by dragging the reference from Zotero into the document or by executing the menu command "Copy as Scannable Cite" from the Edit menu.


    Now let's make a simple test. I have a reference which looks like this:
    Ólafsson, Jéns. Title. London 2020.

    Assuming you have an access to a Mac and Zotero for Mac 5.0.96.2, please be so kind and enter the above mentioned reference into Zotero, then drag the reference into your .odt document, and then perform a ODF Scan. What do you get?

    This is what I get:
    The temporary citation I get looks like this: { | Ólafsson, 2020 | | |zu:0:QTNEGE92}
    Notice that the year is NOT enclosed in brackets as "Working with Citation Markers" demands. According to this instructional site citation markers should look like this: { | Smith, (2012) | | |zu:2433:WQVBH98K}, i.e. the year is in brackets.

    If I now ODF Scan the document with the Default Format in Zotero Preferences > Export > Default Format > Scannable Cite
    I just get the citation "Ólafsson, 2020" (without the quotes) and no brackets which is definitely wrong. NO BIBLIOGRAPHY is created.

    Alternatively, if I ODF Scan the document with the Default Format in Zotero Preferences > Export > Default Format > Chicago Manual of Style 17th edition (author-date) [or any other available style, it doesn't matter which]
    I still get "Ólafsson, 2020" (without the quotes) and no brackets. And NO bibliography is created.
  • If I now ODF Scan the document with the Default Format in Zotero Preferences > Export > Default Format > Scannable Cite
    I just get the citation "Ólafsson, 2020" (without the quotes) and no brackets which is definitely wrong. NO BIBLIOGRAPHY is created.
    That looks like it's working so far. You're just missing the final step -- what you're seeing is just a placeholder citation:
    From
    https://zotero-odf-scan.github.io/zotero-odf-scan/
    Now open the converted document — by default it will have "(citation)" in its file name — in LibreOffice. In the toolbar of the Zotero LibreOffice plugin, click the "Set Document Preferences" button and choose a citation style. Click "OK" and Zotero will format all references in your document. If you want a bibliography, move the cursor to the desired location and click "Insert Bibliography".
  • @adamsmith
    How can I quote text from other members in this forum? The light vertical blue-green line shows me that you are doing it.

    You are right concerning the ODF Scan, I'm missing the final step without which the whole rigmarole is useless.

    I think I can now pinpoint the source of the ODF Scan problem to the fact that the LibreOffice Plugin isn't correctly installed. I tried to install it, both from Zotero and from within LibreOffice (Tools > Extension Manager), but I always get this error message:
    "Could not create Java implementation loader". If I then go to Zotero's Preferences > Cite > Word Processors I can see that "The LibreOffice add-in is currently installed."

    When I start LibreOffice (after having tried to install The LibreOffice add-in) I'm also told that "LibreOffice requires Oracle's Java Development Kit (JDK) on macOS 10.10 or greater to perform this task. Please install them and restart LibreOffice." Obviously this message is referring to the add-in.

    My Java Control Panel in System Preferences says I have the recommended version of Java which is Java 8 Update 291. I'm reluctant to install additional Java.

    Could it simply be that the Zotero for Mac application v5.0.96.2 is NOT COMPATIBLE WITH HighSierra? HighSierra is the last system version I can update to due to my old MacBook Pro, mid 2010.

    Should I delete Zotero v5.0.96.2 and try installing an old(er) version?
  • edited 5 days ago
    <blockquote> something said</blockquote>

    renders:
    something said
  • edited 5 days ago
    The current Zotero requires Mac 10.11 or later. See:
    https://www.zotero.org/support/system_requirements

    Someone else will need to comment on reverting to an older version. __Do Not__ make any changes until someone comments because this has important implications for the structure of your Zotero database and syncing!
  • No, this is an issue on the LibreOffice side, not on the Zotero side, so downgrading Zotero (apart from being generally not advisable) wouldn't help here.

    As both that error message and the Zotero troubleshooting steps: https://www.zotero.org/support/word_processor_plugin_troubleshooting#installation_error say, you need the JDK (not JRE) for MacOS (link to the install page there). I'm afraid there's no alternative to that, so either you install this on your computer, you run the final conversion step on a different machine, or you find a different solution altogether, sorry.
  • edited 5 days ago
    May I ask what you find so appealing about Nisus Writer Pro? It has a very appealing user interface and the collaboration function is handy. However, we (not royal) found that it didn't work well with other software and that its pdf converter had positioning problems.

    LibreOffice 7 with the JDK works fine with our old High Sierra Mac.
  • The current Zotero requires Mac 10.11 or later.
    (Just to avoid confusion: High Sierra is 10.13, so that's fully supported)
Sign In or Register to comment.