Can't open PDF that exists online in iOS app

This discussion was created from comments split from: some pdf can’t open in ios beta version.
  • I'm experiencing this problem. I was previously using WebDAV, but I just bought (a few hours ago as of the writing of this post) a Zotero subscription so that I could annotate PDFs on my iPad.

    I'm able to open the attachment from my web library. The link is https://files.zotero.net/eyJleHBpcmVzIjoxNjE5NTA3MDQ5LCJoYXNoIjoiMmZmOWQwNGYzMjFkN2FiYjk2NTY5Mjg5ZWExY2I1Y2UiLCJjb250ZW50VHlwZSI6ImFwcGxpY2F0aW9uXC9wZGYiLCJjaGFyc2V0IjoiIiwiZmlsZW5hbWUiOiJUb2Nob24tMjAxMy1BIGJyaWVmIGhpc3Rvcnkgb2YgdmlkZW8gZmVlZGJhY2sgYW5kIGl0cyByb2xlIGluIGZvcmVpZ24gbGFuZ3VhZ2UgZWR1Y2F0aW9uLnBkZiJ9/65ad82c92b854027fb5a9ef8cce5bd7583895dbce225859da2fafd3b99f8c8be/Tochon-2013-A brief history of video feedback and its role in foreign language education.pdf

    However, the entry on the iOS beta app shows a question mark on the PDF, and it does not sync. What's my next step to rectify this issue?
  • We'd want to see the URL for the attachment item in your web library, not the temporary files.zotero.net URL, as well as a Debug ID from the iOS app for trying to download the file.
  • edited 19 days ago
    Is this the URL you want?

    https://www.zotero.org/[account]/collections/9FKJVELY/items/FLJPQSEM/attachment/FKAL54CP/collection

    Debug ID from the iOS Beta app: D310272868

    I just set up Zotero Beta on Computer B and synced. The attachment downloaded no problem. Both Computer A and B are Win10 x64. This appears to indicate some problem with iOS syncing the attachments. Hopefully the above Debug ID provides the clue.

    Thanks
  • That looks like a Debug ID for starting the app, not trying to download the file.
  • I started the app, then attempted to sync. Then clicked on the entry, the pdf, etc. Is there some special way to download the file? Like I said, it's got a question mark on it, so the fact that it doesn't download on sync and I can't download it any other way. I'm not sure how you want me to grab a debug ID for something I can't do.

    The only option when long-pressing on the attachment is "Move to trash."

    Please advise the specific set of steps you would like me to take, because the attachment is syncing fine between two Win10 x64 computers; it's only the iOS beta that is problematic for some PDFs (some download, some don't).
  • I'm just asking for a Debug ID for the operation in question, as the linked page explains. Tap "Start Logging" and go tap on the file, and then submit the output. You shouldn't be using the "Start Logging on Next App Launch" option, since starting the app has nothing to do with the problem you're reporting.
  • @TESOLTeacher: If you make a change to the attachment item (e.g., temporarily adding a tag) on the desktop and then sync both devices, does that change anything?
  • edited 19 days ago
    Started logging, then tapped on the file, long-pressed on the file. Opened the info, tapped on the attachment and long-pressed on the attachment.

    Debug ID: D1795489543

    Adding a tag and syncing on a Win10 machine makes no difference as to the attachment on iOS. Still has the question mark, still doesn't download.
  • @dstillman Any update after 6 days?
  • @dstillman I found that by shortening the filename from

    Tochon-2013-A brief history of video feedback and its role in foreign language ecuation.pdf

    to

    Tochon-2013-A brief history of video feedback.pdf

    The file was able to sync. This seems to indicate that there is some sort of filename length limitation on iOS that Zotero has not taken into account.
  • Are you sure it's the length, or was it just updating the attachment remotely? If you change the filename back and sync, can you open it on iOS?
  • It wouldn't sync until I shortened it. That is, until I shortened it on Zotero on the desktop, I could only get an icon with a question mark on iOS. After shortening, the iOS icon changed to the download arrow and is now a regular PDF after downloading.

    Now I've changed the name back to the original on desktop and synced, then synced iOS. The filename has also changed on iOS, but I can still open it.

    It seems like the length definitely has something to do with the sync problem but doesn't matter once the file has been downloaded.

    Is there a specific series of steps you would like me to try with other files? I still have other files with the original long names that still show a ? on iOS; I could send a debug with a specific series of steps if you'd like me to test something out.
  • It's unlikely that the length anything to do with it. What fixed this was almost certainly just making a change to the remote attachment item, which triggered redownloading of the item. You can confirm this by deleting local files from the iOS app's settings and trying again with the same file with the now-long-again filename.

    We've made some changes for the next beta build, which should be out within the next couple days, that should address cases like this where the file isn't available.
  • I'm having the same issue with a lot of my files. How can I manually sync to check whether renaming the file worked? Or do I have to wait for it to automatically sync?
  • Echoing others to say that a good portion of PDFs aren't syncing to the app (from computer), and I'm not sure I make any distinction between those that are able to be downloaded to the app and those that appear with a question mark.

    I've tried the odd renaming idea as well, to no avail :)
  • edited 4 days ago
    @janeayers1001: The renaming, followed by syncing both sides, will almost certainly work if it's actually a stored file and it's been uploaded to the online library. Note that you're at your file storage quota, so some files presumably haven't synced, and Zotero would be warning you about that if you haven't turned off file syncing.

    The next beta version of the iOS app will re-attempt a download when tapping on an item with a missing file, which should address any situations where the file information wasn't properly downloaded. But the file has to actually exist — such that you can view the stored PDF — in your online library to access it on iOS.
  • @dstillman Thank you re: the quota! I had no idea, perhaps missed the message, so that combined with name-changing fixed the issue.
Sign In or Register to comment.