Zotero opened up empty!

Hi,
I have been using Zotero problem free for little over a year and it is awesome. However, I opened Zotero today to find my library empty. I have read through some guidance regarding the location of the local files and it seems to be correct - however I am unable to click the Zotero.sqlite file as this is greyed out.

My online library (Zotero server) appears to be correct and up to date, but the desktop app and library is empty. Can you update your library from the server and download the files?

Also, do you know why this might have happened?

Thanks in advance,

Jamie
  • See Locating Missing Zotero Data, and if you're still having trouble provide the information requested there.

    Usually when this happens it's because someone deleted their previous Zotero database by accident (e.g., while trying to clear up disk space), in which case syncing is the way to go. But we can tell you more if you provide the info requested in that section.
  • (And don't try to open zotero.sqlite — I'm not sure exactly what you're trying to do or what you mean by "grayed out", but nothing says to do that and it won't work.)
  • edited 20 days ago
    Hi, thanks for that.
    Here are the responses to the questions you mentioned:
    The names, sizes, and dates of all files beginning with “zotero.sqlite” in your current data directory
    -zotero.sqlite 987KB
    -zotero.sqlite-journal 990KB
    -zotero.sqlite-bak 987KB
    These were all dated yesterday - when I discovered the problem and tried copying them back as I saw on another help post

    Whether there's a 'storage' folder containing subfolders with dates corresponding to your previous usage of Zotero
    Yes - this appears to be up to date

    Whether your current data directory is in the default location (“Zotero” in your home folder)
    When I click 'Show data directory' it takes me to these folders, so it appears to be in the right place. They 'greyed out' Zotero.sqlite folders mean I cannot move them to change the location (if I needed to).

    When you last used Zotero on this computer, and what happened on your computer since then
    I last used Zotero late last week. The only change on my computer was that I backed up my hard drive to OneDrive - this had a few sync issues. Could this have caused the problem?

    What you've tried so far
    I saw on a post that I could copy the 'Zotero-sqlite' folder and 'storage' onto my desktop and then paste them back into the directory that Zotero uses - but this did not work.

    Thanks
  • OK, so you have only an empty (~1 MB) Zotero database and one automatic backup of that file.

    If you're saying you have a 'storage' folder with subfolders from your previous usage of Zotero, then it's likely what I say above — that you accidentally deleted your Zotero databases while trying to clear disk space. Otherwise, even if something happened to your main database, there would be other, larger database backups in this folder.

    Since you've been using Zotero syncing, you can simply sync to pull down your data from the online library, up to your most recent sync.
    I saw on a post that I could copy the 'Zotero-sqlite' folder and 'storage' onto my desktop and then paste them back into the directory that Zotero uses - but this did not work.
    That sounds like a misunderstanding, but unless you can find another, larger zotero.sqlite somewhere on your computer, it doesn't matter. You can just sync.
  • Thanks for clarifying...

    When I open and click sync, the message below appears:

    'You are about to sync the ‘j.salter’ account to an empty Zotero database. This could happen if you removed your previous database or if the location of your Zotero data directory changed.

    If your Zotero data exists elsewhere on this computer, you should move it to the current data directory or change the data directory location to point to your existing data.'

    I am worried that I will overwrite my Zotero server database with a blank one if I do this? Is that not the case?

    Please could you advise on this.

    Thank You
  • That’s just warning you that your database is missing. It’s not going to overwrite anything.
  • Done - currently syncing.

    Thanks you for your help and speedy response. PhD thesis almost finished so I was a little panicked at one point.
Sign In or Register to comment.