Good Docs Zotero tab won't connect to Desktop App

I have the Zotero connector in my Chrome browser the the tab does populate in my google doc - however, when I attempt to add a citation it says that "The Zotero Connector was unable to communicate with the Zotero desktop application. Zotero must be open to use web-based citing."

I've trouble shot my connection, my chrome browser extension has full access to the tab, I've restarted both the browser and the desktop application, redownloaded and upgraded the desktop application, and when I load the "connector ping" it says that my server is available, but it still says that the google doc is unable to communicate w/ the desktop app.

Please help!
  • We'll look at a Report ID from the connector, but I'm afraid there's likely nothing more we can say other than what's on the support page. If you can load the ping page from Chrome, something in your Chrome installation is blocking the connector from talking to the desktop app. E.g., it doesn't sound like you've tried disabling other extensions, as suggested there.
  • Thanks - I've checked my extensions and I only have google doc and the zotero extension, no other extensions in my chrome.
    Please let me know what else I should look for/can do.
  • You can try creating a new Chrome profile. Again, this is a problem in Chrome. The Zotero Connector should be able to connect to anything you can connect to in the address bar, so if that's not happening, you'll have to debug your Chrome installation to figure out what's wrong.
  • edited April 22, 2021
    Okay - I've continued looking into this and got rid of my other extensions altogether and tried to debug as you suggested but was still unable to get this to work on Chrome.

    I've switched to Microsoft Edge and it seems to be working.

  • Did you try a new Chrome profile?
Sign In or Register to comment.