OneDrive Issues

Hello,

Just flagging up the (apparently) common issue with OneDrive documents and Zotero. It was working absolutely fine (with spaces in my document names - I wasn't even aware there was a potential issue) for multiple documents until today.

Today however, when I open a document from OneDrive and click on anything within the Zotero tab it flags up an "Integration Error" and says: "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"

I've managed to resave the document without any spaces and that does seem to fix the problem, but I have a whole thesis full of chapters to now rename.

It may not be linked but the last thing I did to the document and Zotero yesterday was to renew my subscription for storage - the problem has only occurred since then.

Is there a debug for this error in progress? Am I just resigned to renaming my chapters or might this be fixed soon?

Thank you so much,

Lottie
  • I have had the same issue occur today - I hadn't actually identified it as a possible OneDrive issue until reading this though.

    Followed all troubleshooting steps and also did a complete uninstall/delete and redownload and install for both Word and Zotero, with no change in outcome.
  • I wouldn't expect this to get fixed any time soon, so yes, either moving files out of OneDrive or removing the spaces is currently the recommendation.
  • edited May 6, 2021
    I'm having the same issue. I've identified a two-step temporary bandage that works for me: (1) Exit the OneDrive app on my computer (by going to the system tray, right-clicking OneDrive, and selecting "Close OneDrive") and then (2) Move the Word doc to any other folder in my OneDrive. But I have to do both steps, not just one or the other. I'm not sure what this two-step procedure implies about the nature of the problem though. I've been operating in a Google Drive environment (with the Google Drive sync app in my Windows OS), but a couple days ago I started using OneDrive and today I've become aware of this issue (I think today is the first day I've attempted to use the Zotero Word plugin with any file in my OneDrive).
    Edit: Also, I was able to "fix" the issue by renaming the Word doc file with no spaces, as noted elsewhere in the Zotero help documentation/forums.
  • Hey! I was having the same issue just now. I've just tried to update my Office and it worked. Hope it will keep working. I'll keep you posted.
  • edited June 3, 2021
    As of today (June 3, 2021) I'm noticing the issue seems to have magically resolved itself in my computer! I have MS Word files stored directly in OneDrive and everything about the Zotero plugin seems to be working perfectly. As far as I know, I did not change any OneDrive settings or anything. Maybe it was an automatic software update somewhere.

    Edit: I have the 64-bit version of Windows 10 Home.
  • Hi.
    I've experienced few minutes ago same issue with Microsoft desk apps.

    It seems resolved now.

    First I have duplicated the file.
    Then I've changed name's file by eliminating spaces. And when I opened the file,it was working as expected.

    Hope you find it useful.
  • So strange. OneDrive and Zotero have always worked together perfectly well for me. But just this morning, I got the "Zotero experienced an error updating your document" message. Sure enough, removing spaces from the file name (without even closing the file) fixes the issue.

    In case it's helpful, here are the pertinent system details:

    - Microsoft® Word for Microsoft 365 MSO (16.0.14228.20158) 64-bit
    - Windows 10 Pro, 21H1, 19043.1110
    - Zotero 5.0.96.2

    If I can provide anything else that might be useful, please feel free to ask.

    Thanks so much.
  • I have the same issue. Zotero showing "Zotero experienced an error updating your document" message.
    Report ID :1891604082
  • My issue has now apparently resolved itself. I'm not sure if it was the recent update to the OneDrive client, Windows (to 19043.1165), or Word (to 16.0.14326.20062). But things seem to be working as expected again, even with spaces in the file name.
  • edited August 19, 2021
    And now the issue is appearing again, this time on a different machine. But it still resolves when I remove spaces from the filename.

    Specifications are below:

    - Word for Microsoft 365 (16.0.14326.20122) 64-bit
    - Windows 10 Home, 21H1, 19043.1165
    - OneDrive 21.160.0808.0001
    - Zotero 5.0.97-beta.37+ddc7be75c

    If I can provide anything further, please feel free to ask.

    Thank you so much for any thoughts anyone may have!
  • Been having the same problem. This works for me:
    - close OneDrive, or just pause syncing.
    - Open the document. (Close then re-open if you had it open already.)
  • That works for me as well, @timvangelder.
Sign In or Register to comment.