Zotero iOS v. 1.0 (111) crashes on iOS 14.4.2/iPhone 8

Crash report sent.
  • edited 22 days ago
    What are you doing when it crashes? Can you reproduce it?
  • It crashes every time I try to open (launch) the app.
  • iPhone 12 Pro with iOS 14.5 beta: Zotero 1.0 (111) crashes immediately when launched. Re-installed 1.0 (109) and everything is fine.
  • Same here on iPhone max pro 11 with iOS 14.4.2. I could not get the app to start at all. Went back to 109 and all good.
  • Thanks all for reporting the issue. I'm sorry you got startup crashes in build 111. Since they happen to you on startup every time, I'm not getting any relevant info from your devices, because there is not enough time before they crash.

    Could @ehud, @wyssusek or @burgarth do the following for me:
    1. Go to "Setttings" on your device
    2. Choose "Privacy"
    3. On bottom choose "Analytics & Improvements"
    4. Choose "Analytics Data"
    5. Drag the list down and search for "Zotero"
    6. You should see some results with this format "Zotero-year-month-date-somenumbers.ips", open result with newest date.
    7. In top right corner you have the Share button, save it and share it here please.

    This way I'll have more info and I'll be able to resolve the crash. Thanks again!
  • I suppose this is the relevant part:

    Exception Type: EXC_CRASH (SIGKILL)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Exception Note: EXC_CORPSE_NOTIFY
    Termination Reason: Namespace SPRINGBOARD, Code 0x8badf00d
    Termination Description: SPRINGBOARD, :31787 exhausted real (wall clock) time allowance of 19.85 seconds | ProcessVisibility: Background | ProcessState: Running | WatchdogEvent: scene-create | WatchdogVisibility: Foreground | WatchdogCPUStatistics: ( | "Elapsed total CPU time (seconds): 29.220 (user 29.220, system 0.000), 25% CPU", | "Elapsed application CPU time (seconds): 6.096, 5% CPU" | ) reportType:CrashLog maxTerminationResistance:Interactive>
    Triggered by Thread: 0

    I have a rather big library, perhaps the app tries to re-format the database at startup?
  • Thanks burgarth. Could you share the whole thing?
  • It's rather large. Can I email it?
  • edited 21 days ago
    Sure, send it to support@zotero.org
  • Same problem on my iPad by the way.
  • Michael I sent it to your originally posted mail. Thanks.
  • Emailed the data to support@zotero.
  • Same here in latest 12.9" iPad
  • We've got a new build (112) out for you. I hope it fixes the crashing issue for all who had it. If not please let me know.
  • Great that did the job for me, thanks Michal!
  • Yay! Works fine now. Many thanks.
  • @michalrentka it's working again, thanks!
Sign In or Register to comment.