OOo Integration 3.0a2 won't install the OOo extension

On Windows with Firefox 3.5.3 and Zotero 2.0b7.1, the integration plug-in does not update the OOo Integration extension from 3.0a1 to 3.0a2 on one of my machines, but it worked fine on the other. Removing the OOo extension and the FF add-on and reinstalling the FF add-on does not solve the problem. How can I clean things up so they install properly? Thanks.
  • Same here. On my Mac, Mac OS 10.5.8, FF 3.5.3, NeoOffice 3.0 Patch 7, Zotero 2.0b7.1, Zotero OpenOffice Integration 3.0a1 (I installed 3.0a2) I get the following error message:

    Gruesse, Pablo

    Jim: If it's working, don't worry about it.

    Pablo: Check that you have the latest Java version from (Apple) Software Update.
  • Thanks, Dan,
    It's working,, so I won't break it.
  • edited September 18, 2009
    I am having a similar problem under Ubuntu 9.04:

    The main problem is that I cannot see the Zotero toolbar in OO3.11.

    I have, as suggested on the install page, reinstalled the OO components from within Firefox (3.5.2) (via the FF Add-on Preferences route) and appended are my java plugins:

    I do "see" Zotero OpenOffice Integration 3.0a1 (note 1 not 2) in the OO Writer extension manager (FF reports the add-on as 3.0a2 - probably just a version annotation issue)

    What I do not see is the zotero citation toolbar within OO.

    Thanks again (and again) for all the creative software and the remarkable user support.


    snipit from about:plugins

    pplication/x-java-vm Java™ Plug-in Yes
    application/x-java-applet Java™ Plug-in Applet Yes
    application/x-java-applet;version=1.1 Java™ Plug-in Yes
    application/x-java-applet;version=1.1.1 Java™ Plug-in Yes
    application/x-java-applet;version=1.1.2 Java™ Plug-in Yes
    application/x-java-applet;version=1.1.3 Java™ Plug-in Yes
    application/x-java-applet;version=1.2 Java™ Plug-in Yes
    application/x-java-applet;version=1.2.1 Java™ Plug-in Yes
    application/x-java-applet;version=1.2.2 Java™ Plug-in Yes
    application/x-java-applet;version=1.3 Java™ Plug-in Yes
    application/x-java-applet;version=1.3.1 Java™ Plug-in Yes
    application/x-java-applet;version=1.4 Java™ Plug-in Yes
    application/x-java-applet;version=1.4.1 Java™ Plug-in Yes
    application/x-java-applet;version=1.4.2 Java™ Plug-in Yes
    application/x-java-applet;version=1.5 Java™ Plug-in Yes
    application/x-java-applet;version=1.6 Java™ Plug-in Yes
    application/x-java-applet;jpi-version=1.6.0_16 Java™ Plug-in Yes
    application/x-java-bean Java™ Plug-in JavaBeans Yes
    application/x-java-bean;version=1.1 Java™ Plug-in Yes
    application/x-java-bean;version=1.1.1 Java™ Plug-in Yes
    application/x-java-bean;version=1.1.2 Java™ Plug-in Yes
    application/x-java-bean;version=1.1.3 Java™ Plug-in Yes
    application/x-java-bean;version=1.2 Java™ Plug-in Yes
    application/x-java-bean;version=1.2.1 Java™ Plug-in Yes
    application/x-java-bean;version=1.2.2 Java™ Plug-in Yes
    application/x-java-bean;version=1.3 Java™ Plug-in Yes
    application/x-java-bean;version=1.3.1 Java™ Plug-in Yes
    application/x-java-bean;version=1.4 Java™ Plug-in Yes
    application/x-java-bean;version=1.4.1 Java™ Plug-in Yes
    application/x-java-bean;version=1.4.2 Java™ Plug-in Yes
    application/x-java-bean;version=1.5 Java™ Plug-in Yes
    application/x-java-bean;version=1.6 Java™ Plug-in Yes
    application/x-java-bean;jpi-version=1.6.0_16 Java™ Plug-in Yes
  • Rob, is the Zotero toolbar available under View->Toolbars?
  • The new toolbar doesn't work for me either. I have Zotero 2.0b7.1, Suse 11.1, OpenOffice and the only java plugin available "java-1_6_0-openjdk-plugin - Java web browser plugin based on OpenJDK 6 and IcedTea 6. This package provides a Java plugin for using Java applets in web browsers such as FireFox. It is based on gcjwebplugin using OpenJDK 6 and IcedTea 6". It provides "IcedTea Java Web Browser Plugin File name: The IcedTea Java Web Browser Plugin 1.5.1 (suse-0.1.2-i386) executes Java applets."
    After an OpenOffice message that OpenOffice plugin 2.0a1 (I think) was incompatible with Zotero 2.0b7.0 at that stage, I removed the plug-in using OpenOffice/Tools/Extension Manager. After updating to Zotero 2.0b7.1 and reopening OpenOffice, I have a new style of toolbar with text instead of icons. Unfortunately, this new toolbar doesn't work. It also inconveniently crowds the toolbars.
    Just want to add that Zotero is an excellent tool!
  • stuartn, the IcedTea plug-in doesn't work with Zotero because it doesn't fully implement the API for a Java plug-in. My copy of SuSE 11.1 shows a java-1_6_0-sun-plugin package, which does work with Zotero.

    The icon issue may be independent (I don't see it on a fresh install, either), but you may be able to fix it by closing OpenOffice, going to Tools->Add-ons->Extensions, clicking the "Preferences" button next to Zotero OpenOffice Integration, and then clicking "Reinstall OpenOffice Components".
  • Hi Simon, I installed "java-1_6_0-sun-plugin" and needed to deinstall "java-1_6_0-openjdk-plugin" so the new sun-plugin would show up in Firefox "about: plugins". The toolbar is still present in OOwriter but still doesn't work. For some reason I can't find "Reinstall OpenOffice Components" according to the sequence "Tools->Add-ons->Extensions"/Zotero "Preferences". Is it supposed to be on the "General" tab? Also, there is no Zotero extension showing in OOwriter "Extension Manager", should there be one? Thanks, Stuart
  • You need to click "Preferences" next to Zotero OpenOffice Integration, not Zotero. If you don't see Zotero OpenOffice Integration in Tools->Add-ons->Extensions, you should re-install the plug-in.
  • Simon, which plug-in? I downloaded Zotero-OpenOffice-Plugin-3.0a2.xpi but OpenOffice will not accept it as an Extension. Stuart
  • It's a Firefox extension, not an OpenOffice extension.
  • Simon, installing that xpi in Firefox via "drag and drop" was the hardest bit! Everything seems fine now - and the tool bar has returned to icons. I really appreciate your help! Stuart
  • @Dan:
    mymacbook:~ pablo$ java -version
    java version "1.5.0_20"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_20-b02-315)
    Java HotSpot(TM) Client VM (build 1.5.0_20-141, mixed mode, sharing)
    mymacbook:~ pablo$

    It's the latest for Mac OS X Leopard.

    Gruesse, Pablo
  • edited September 19, 2009
    Oh well, I deactivated Java in Firefox for security reasons the last time Apple did not update their Java distribution for months. Everything works now… ;-)

    Gruesse, Pablo
  • Further help would be appreciated .... while everything is ok in a new document in OpenOffice, I receive major errors with an existing document. For example, I open an existing document with many references, then use the Document Preferences icon. Firstly, it shows "Reference Marks" when it should be "Bookmarks". After selecting bookmarks and OK, there is a dialog saying that the document must be upgraded. Answering yes, the process quickly completes. Then attempting to insert a citation, there is a major Zotero Integration error.
    "An error occurred communicating with Zotero
    java.lang.Exception : Invalid code prefix
    at sun.reflect.GeneratedMethodAccessor8.invoke(Unknown Source)
    at sun.reflect.DelegatingMathodAccessorImpl.Invoke(
  • Oh, in the above post, the Document Preferences first raises the Upgrade dialog, which then completes and opens the Document Preferences dialog.
  • edited September 19, 2009
    Regarding finding the Zotero toolbar within OO3.1.1.

    I did find the toolbar - it is denoted (unhelpfully) "Add-on 1" and it installed (as graphics) onto the otherwise textual 003.1.1 toolbar. OK, so far so good.

    However, I am not getting the "could not communicate" error which has been reported in the other active thread on this matter. Further attempts to contact Zotero from within OO (by using the icons) yield a "Zotero experienced an error updating your document" error.
  • SalishSea, can you provide a report ID?
  • Simon,

    I removed the OO WRiter extension, then tried within Firefox to use
    Tools/Add-ons/Zotero OO Integration 3.0a2/Preferences

    with the following settings:
    Java URE

    soffice Directory

    and then attempted to Reinstall OO components.

    This generated the following error window :

    Zotero OpenOffice Integration could not complete installation because an error occurred. Please ensure that OpenOffice is closed, then restart Firefox.

    and the following

    error in the Report Errors log:

    [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIProcess.init]" nsresult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)" location: "JS frame :: chrome://zotero-openoffice-integration/content/browser-overlay.js ::

    Submitted Error Report as: 1008107124
  • SalishSea, I've just written some instructions that might help you find your OpenOffice directories. Look here.
  • Simon,

    Thanks for instructions. Very helpful.

    I'm still not getting to the goal line despite your kind efforts and the instruction page.

    See my comments:

    Here's the current Report Error number: 724474210

    Thanks to all the Zotero team for a great tool. Most of us cannot imagine maintaining a tool that involves so many seemingly-moving parts (OS, java variants, alternative paths, various bits and pieces of other Open Source code, etc).

    Kudos again.
  • Simon, Further to my posts about errors above with Suse 11.1 and OO Writer, I would like to let you know my experience. I worked through your troubleshooter but it didn't identify the problem. The root of the problem seemed to be that my existing documents using Bookmarks just wouldn't work. So I "bit the bullet" and changed my dissertation over to References instead of Bookmarks. When Zotereo asked for permission to update I just say yes and allow the default of References. Now everything works fine and I'm cruising again. In fact, References are much better than Bookmarks because they are more visible. Thanks again for a really incredible product and your fabulous support!!
Sign In or Register to comment.