Troubleshooting with Juris-M, Macbook Air M1 and an old document


I am Juris-M's user (ver.5.0.93m18). I am doing my dissertation for two years now with Juris-M with my older Macbook Pro 2015 and Word processor. However, I bought a new Macbook Air with M1 processor, installed the programs, and tried to refresh citations in my work but the "Jurism experienced an error updating your document. Would you like to view troubleshooting instruction?" sign appeared.

I have tried all the different solutions advice in troubleshooting, but none of them solved the issue. When copying and pasting the old references in my new laptop from the old document to a new one, some of them work and others do not. A particular case is interesting: when citing together two or more specific authors Juris-M does not work, but, when citing them separately, it works fine. However, with other authors, it is feasible to cite more than one author without problems.

I want to stress that my old computer is able to refresh the same entire document, including the bibliography, without problems, and despite the fact that both are using exactly the same software as the new one (Word, Juris-M and including the macOS Big Sur Ver. 11.2.3).

Anyone who knows how to solve this issue?
  • This is a macOS bug that we worked around in Zotero in January. I don't know the status of Jurism. It looks like the changes were merged, but I'm not sure if there was a release with those changes.

    If a fix isn't available, the only workaround would be running Word under Rosetta via File → Get Info (and setting a reminder to come back and check in several months to see if it's resolved so Word doesn't run slower and use up more battery in perpetuity).
  • Thank you very much!
    You made my day.
Sign In or Register to comment.