Can't download Pdf


I'm currently unable to download pdf from different websites (like jstor, etc.). I'm connected to those sites with my university proxy.
I tried on two browsers (edge and firefox) and none worked.
Strange thing for me is that on my other computer, it is working fine with Firefox. As far as I can tell, the settings are the same on both computers. So I'm confused.
here's an debug ID : D1548223120

  • Do you mean that you're getting a red X for the PDF in the save popup?

    Can you provide a Debug ID from Zotero (rather than the Zotero Connector) for an attempt that fails?
  • Yes, I'm getting a red cross for the pdf. Here's the correct ID : 1198230131
  • That’s a Report ID, not a Debug ID.
  • Ok my bad :) I think it should be this one : D974525771
  • www-jstor-org.proxy.[…].fr:443 uses an invalid security certificate.

    The certificate is not trusted because the issuer certificate is unknown.
    The server might not be sending the appropriate intermediate certificates.
    An additional root certificate may need to be imported.
    Your proxy server is incorrectly configured. You'll need to report this to your library or IT department. You can point them to the technical explanation here (and if you put in the real domain name in the URL above, you can see that the server shows an error about the certificate chain on the linked test):
  • Thanks ! But there's something I don't understand, because it is working on my other computer, and I'm using the same proxy.
  • The proxy may have been previously configured to serve the intermediate certificate, or you may have saved without the proxy from a site that served the intermediate certificate. In either case, the intermediate certificate would then be cached in Zotero, and you'd be able to connect to the proxy server in its current incorrect state.
  • Ok, thanks for the info !
Sign In or Register to comment.