Citations unlinked in Google Docs

This discussion was created from comments split from: Link citation again.
  • I actually just clicked "refresh" in a google doc and it unlinked all my zotero citations without asking. For some reason goggle doc was unable to reverse this last step.

    Luckily, I had saved a copy right before, so I was able to get back all my properly linked citations...
  • If that happens -- though it seems very strange -- that's of course a bug, but a very different topic from the unlink citation button.
  • edited March 12, 2021
    Thanks for splitting this off.

    Now I am finally stranded, so I will explain the whole story:

    1. I started working on a manuscript in google docs with zotero and everything worked just fine.
    2. I then decided to use use the journal's formatting template, which of course came as .dot (MS word template). For this purpose I followed the instructions on transferring a google doc to MS word including the Zotero linked citations (https://www.zotero.org/support/kb/moving_documents_between_word_processors). This also worked just fine and I copy/pasted the manuscript text into the .dot template and saved it as .docx (linked citations still there).
    3. Now I worked the other way, going back to google doc (switch word processors, save as docx in MSword, open docx in google docs, save as gdoc, refresh), and voila, a nicely formatted google doc with linked zotero citations intact.
    4. Today I open the gdoc - my collaborator had edited a few things - it still looks fine, but when I want to add a citation/refresh or do anything involving zotero, it immediately unlinks all my citations, with no chance of undoing it.

    Details:
    - My collaborator does not have Zotero or the connector installed, but I think this is irrelevant.
    - Could it be the .dot template?

    I kept a copy of the gdoc with the citations still linked (at least it looks like it, since once use zotero it will unlink all of them). Any idea how I could avoid having to manually relink all citations?
  • How did you ensure that all citations were linked in step 3? That's the first bit where I see some chances something went wrong.

    More likely, however, this is indeed related to your collaborator: if they e.g. copied text with citations, it'd have gotten unlinked. Crucially, unlinked citations only show as unlinked when Zotero becomes aware of it, so it's not actually the Refresh action that does this -- it just becomes _visible_ at that point (which is also why undo won't fix it).

    The best way to troubleshoot would be to make a copy of the document at its current state so you have all edits saved and then go back in the version history of the existing doc to track down when citations got unlinked.
  • Just tried to edit a citation, it unlinked all citations (as expected) and popped the following error:
    "Selected field 9VK928 not returned from Docs backend"
    not sure if this helps...
  • - My collaborator does not have Zotero or the connector installed, but I think this is irrelevant.
    No, that's extremely relevant. Everyone collaborating on the Google Doc needs to have the Zotero Connector installed.

    Just to reiterate what adamsmith said, the citations were unlinked previously to when you did the Refresh. The Refresh is simply when Zotero detected the unlinking and notified you.

    Since this was in Google Docs, you should be able to use the document's version history to find a previous version from before the citations were unlinked and make a copy of that. The key thing to understand is that it's not the Refresh that unlinked it, so you have to go back to a version before whatever actually happened — likely something by your collaborator — that broke the citations. You'll know you found the right version when you can do the Refresh without the citations turning red and the warning showing up.
  • It makes sense to me what you guys are saying about the citations already being unlinked before actually showing up as unlinked.

    However, even when I work myself back to the first version after importing the manuscript to google docs (step 3), "Refresh" unlinks all citations. This is odd because at that time I had just used "refresh" to link all citations (I was coming from docx via "switching word processors"), which obviously worked. At this point my collaborator hadn't even touched the document yet.

    Is there any way the latter steps could've impacted the earlier version saved by google docs?

    I even just now went back to step 3 with the docx file I used for switching word processors, saved it as gdoc and "refresh" again does the job perfectly.

    Now I have an old version with working citations and a new version with a bunch of suggestions from my collaborator, however, with unlinked citations...
  • For all the testing we have done reverting to an earlier version usually works, but if it does not it's hard to say why it doesn't work since it's a Google Docs functionality and it may be misbehaving. You could try to use the Compare Documents option under Tools in Google Docs to update the document with Zotero citations intact with your colleagues work.
  • @melgeti: You probably know this, but note that Google Docs groups revisions in the Version History, so you may need to expand an entry to see all the possible revisions.
Sign In or Register to comment.