Citation ribbon opening behind MS Word

Clicking the "add/edit citation" option in Word (Office 2019 for Mac) causes the Zotero citation "ribbon" to open behind the Word document. I have to shrink Word and keep the ribbon open next to the document in order to use it.

Any thoughts/suggestions?
  • It might help if instead of minimizing Zotero when switching to another app you simply switch to it without clicking the "-" icon. Otherwise, this isn't a general problem, so there is something about your workflow or other software configuration that may cause this.
  • I must have not explained this properly. When trying to add citations or a bibliography in Word, the citation dialog Zotero box opens behind Word, so I can't see it without making my Word document small.
  • No, I did understand. But note that minimizing the Zotero window (as opposed to switching to another window, e.g. by clicking on Word in the dash) may be causing this. If you're not minimizing Zotero, then you can try to do some more thorough troubleshooting. Close all open applications and restart your Mac. Open just Zotero and Word and try citing. Do you still see this behavior?
  • Thanks for your patience. I would love to get this sorted as I assist students with Zotero and it has been really awkward during webinars.

    Here's what may be relevant:

    I have been able to reproduce this issue on my 2 different Macs - one has the most current OS, the other is running one OS behind. I have MS Word (Office for Mac 2019) - 2 different licenses for each Mac, both updated.
    I have tried uninstalling Zotero and the browser connectors on Firefox and Chrome, and then reinstalling all.

    Here's exactly what happens:
    I open Zotero.
    I open Word.
    I click "Add/edit citations"
    Word slides off my screen and the Zotero- Document Preferences - Citation Style window pops up.
    Once I select my citation style, the citation dialog box (I call it a ribbon) pops up, but Word is not on my screen.
    When I click on the Word doc that has been automatically minimized, the ribbon is covered by my Word document. I can't get it in front of my Word doc at all. The only way I've been able to demo it is to partially minimize Word and then drag the citation dialog ribbon partially over my Word and the other part hangs over on my desktop. This wouldn't be that bad if I needed to actually use Zotero to do citations, but I'm mostly teaching it to students, and it's just clunky.

    Thanks again for your help.
  • I didn't realize you had Word maximized to a workspace. Unfortunately we are unable to draw the citation dialog over maximized windows. You can expand the Word window to take up the whole screen by dragging it by the edges instead of using it in the maximized mode, which will allow Zotero to display the citation dialog over it.
  • I Have had the exact same issue as this user- trying to figure it out for hours. It also didn't use to do this, then just started happening & now remains. Surely it can't be the case that you can't have a maximized Word window and add a Zotero citation at the same time???
  • Unfortunately Zotero cannot display the citation dialog over full-screen MacOS applications. This is a limitation of the Firefox platform that we are based on. We will be able to do it as soon as Firefox gains that ability, which is currently not available even on the newest version of Firefox.
Sign In or Register to comment.