Google docs Zotero won't cite, just pulls up link function

2»
  • Still exactly the same for me with the new connector. One account works (still), the other brings up the Google add link box when I hit 'add citation'.
  • I'm experiencing the same problem. Was Zotero connector was working fine in Firefox last night, today it just brings up the link box. Have installed Chrome in case it was a Firefox issue and the same problem exists with Chrome.
  • edited March 2, 2021
    Having the same issues, here is the div code using a chromium based browser (brave) on linux mint.
    <div class="docs-calloutbubble-anchor" style="left: 661.125px; top: 1314px;"></div>
  • @Mmanierre @adampricehydro @Joby @henryfg @plxdw1 @oa270100 Thanks for help with troubleshooting this. I've managed to reproduce the error and we will have a fix for the Zotero Connector Beta for Firefox available within the next 24hrs. We will post an update here when the fix is through.
  • Glad to hear it, thank you for keeping on top of this and working with us to pin it down.
  • I have the same issue.

    Working on a Google account from an organization, in Win10 PC and Firefox. The weird thing is that I can edit Gdocs with Zotero in my private account.

    I am not asked to allow permission to Zotero to access my organization account, while it still does ask for permission in my personal account.

    Error ID Firefox: 1203769405

    I reproduced the same error in Microsoft Edge.
  • @Mmanierre @adampricehydro @Joby @henryfg @plxdw1 @oa270100 @mvsabahell: The fix is now available in the Zotero Connector Beta. If you use Firefox and have been seeing this issue, please try that and let us know if the problem is resolved for you. Once we have confirmation that this is working well, we'll release this for everyone.
  • Ok, it is working for me

    ;)
  • Seems to be working for me now as well! Unless something changes I think this was the fix.

    Thanks for the hard work!
  • OK, thanks for letting us know. We've pushed this fix out with Zotero Connector 5.0.82 for Firefox, so if you installed the beta, you can switch back to that if you want. Edge should get the update within 24 hours. Extensions for Chrome unfortunately can take a few days, but we'll post here when it's available.
  • I'll snag the chrome update when it comes through and let you know if it works! I haven't had a chance to play with the patch in firefox, but I'm optimistic from other people's comments.
  • @dstillman you hero! All working properly again for firefox on linux, plenty of time to chuck in the edits before the deadline
    Thanks again
  • Same problem on chrome. Waiting for update, hope will fix
  • Zotero Connector 5.0.82 for Chrome is out now. You can check whether you have it from the Chrome Extensions pane, and click Update if not. Then reload Google Docs.
  • Got it, confirmed to be working for me on Chromium! Thank you!!!
  • Ah great just realised I was back in Chrome (rather than my Firefox other account workaround) and it's all working as it should. Much appreciated.
  • no luck yet with Jurism
  • I have the same problem on Mac using Safari. Any hope for fixing this?
  • Same problem on Mac with Safari. Firefox also still not working; but Chrome does work (which is my workaround for now).
  • Still having problems with google docs on safari
  • Ditto on google docs and safari
  • This should be fixed for Safari users in the latest Zotero beta. As usual with the beta Safari extension, you'll want to delete the Zotero beta from Applications and redownload it (possibly restarting your computer in between) to get the updated extension in Safari.
  • Hi,

    I have the zotero connector 5.0.84 but still have the pop up issues.

    Any advice?
  • @SB_UCL: What browser? If you're still seeing this, can you follow the steps in this post?
  • It is chrome, I have just sent you the information by email.

    Any advice will be greatly appreciated!
  • Do you see any action from Zotero (a progress bar, citation dialog) at all or do you simply get the popup in Google Docs? Are the fields in the Google Docs popup empty? Are you using an institutional or a personal Google account? Have you tried disabling other extensions in Chrome?
  • Hi,
    No progress bar or citation dialogue, just the popup in google docs.
    Fields are blank in pop-up box.
    I am using a personal google account.
    I have removed all other extensions from Chrome.
    I hope this helps.
  • To add:
    if I copy and paste within the document, zotero manages to maintain the citation links already inputted before this bug occurred.
    it is when I wish to input a new citation...
  • Could you try installing the Zotero Connector into Firefox and see whether you see the same issue there too? When you open the developer tools in Chrome could you switch to the console tab. Then try to insert a citation with Zotero. Do any messages get logged in the console? If so, could you paste them somewhere (like pastebin.com) and post a link here?
Sign In or Register to comment.