Zotero Standalone won't open


I just installed a fresh copy of windows 10 and installed the latest version ( of Zotero Standalone available on the website.

I am getting the following error message when trying to launch it:
Win error 21 during operation open on file E:\BS Research Zotero Directory\zotero.sqlite (The device is not ready.

(No stack trace)
From previous event:


My Zotero library is stored on the local hard disk in D drive. It was working fine on the old windows installation. The error seems to refer to the database in drive E:\ which is strange.
1. I tried installing Zotero again after using C-cleaner to wipe out any cookies and temp files. Same issue persists.
2. I have already tried running the latest Zotero beta, Windows ZIP version. Didn’t work.
3. I also tried uploading my database to the DB Repair Tool. I imported it back and it also didn’t work. Upload ID 6036813151c4b

There is no zotero.sqlite.105.bak file in my profile folder.

Please help me resolve this issue at the earliest.

  • Was it the E: drive on the other computer? Did you configure the data directory location on this computer or did you copy over Zotero profile directory from the other computer?

    In any case, you can delete prefs.js in your profile directory and try setting the data directory location again.
  • Thank you for your response. This profile has all my research, and this error is making me sweat.

    Yes, the E drive on my last computer had the profile directory.

    On this new installation, I had no chance of directing Zotero to the profile directory which I copied over to D drive. Zotero just gives me the error splash screen.

    I can't locate prefs.js in the directory. Where exactly should it be?

  • I tried looking for prefs.js using Everything App. I found a few files with this name. None of the file paths were associated with the Zotero Profile directory.
    I deleted one from Appdata for Zotero, and now Zotero won't even start.
  • edited February 25, 2021
    You're misunderstanding a couple parts of this.

    Your Zotero data directory contains your data.

    Your Zotero profile directory contains settings, including the path to your custom data directory. prefs.js is located in the profile directory. I linked to instructions above, and here, for locating it. You shouldn't be searching for anything.

    If Zotero is looking in E: for your data directory, it sounds like you copied over your profile directory from the other computer. We don't generally recommend that, in part because of problems like this — there's no reason to think a custom data directory location would be in the same place on different computers.

    You should just close Zotero and delete prefs.js in your Zotero profile directory. Zotero will then start up using the default data directory location, which is "Zotero" in your home folder. That should be an empty database (assuming you haven't put data there or synced), and you'll be able to point it to your custom location if you want to. To avoid later confusion, you can then delete the new "Zotero" folder with an 1 MB or 5 MB zotero.sqlite file in your home folder.
  • I reinstalled Zotero, went to the profile directory as instructed in the link, and deleted the prefs file.
    I got the same error splash screen.

    Side note:
    In the future, if I want to move my Zotero data to a new computer, what should I do instead of copying my Zotero data folder?
  • I am amazed how a fresh installation of Zotero on a new computer, with a freshly installed Win10 knows that it has to look in E: drive for the data folder.
  • If you've deleted prefs.js in your active Zotero profile directory and Zotero is still looking on the E: drive, I'd guess that you have a Firefox profile that you used with Zotero for Firefox years ago (possibly synced via Firefox Sync). If so, you can close Firefox, open prefs.js from any Firefox profile directories you have in a text editor (e.g., Notepad), delete any "zotero" lines you see, and save the file.
    In the future, if I want to move my Zotero data to a new computer, what should I do instead of copying my Zotero data folder?
    That's exactly the thing to do (or you can use Zotero sync). You may just be in a very weird situation where 1) you used Zotero for Firefox years ago, 2) you had a custom data directory location that was valid on one computer and resulted in an unexpected device error on another, 3) the old Zotero for Firefox preferences were synced via Firefox Sync, and 4) you did a first-time install of Zotero on this computer, causing it to find the old Firefox pref and attempt to use that data directory so still had access to your library.
  • Yes, I used to sync Zotero years ago.
    My ISP's upload speed isn't great, so I shifted from online backups via Zotero for Firefox to just backing up my data directory to an external drive.

    I have edited the prefs file in Firefox directory and now Zotero has finally started!
    I was able to link it to my Backup data folder, and it has imported my library :)

    Thank you for saving the day!
  • edited February 25, 2021
    OK, great. Again, if you have a newly created "Zotero" folder in your home directory with a 1 MB or 5 MB zotero.sqlite file, you should delete that folder to avoid future confusion.
  • Done!
    Thanks again for your help :)
Sign In or Register to comment.