Trouble adding bibliography in google docs

edited yesterday at 4:07pm
Hello Zotero users,

I've been using Zotero to cite multiple texts in a google docs document, and now I am trying to add the bibliography. The problem is that the bibliography is not displaying correctly; zotero is copying an encoded version of the bibligraphy.

What causes this error?
What can I do to fix it?

I'm using APA7.

When I try to edit the bibliography, zotero gives me this message: "Selected field 6JKgfg not returned from Docs backend".

This is how the bibliography looks:

Bibliography:

<div class="csl-bib-body">
<div class="csl-entry">Askeland, Norunn, og Magdalena Agdestein. 2019. <i>Metaforer: hva, hvor og hvorfor?</i> Oslo: Universitetsforlaget. <a href="https://www.nb.no/search?q=oaiid:"oai:nb.bibsys.no:999919995985802202"&#38;mediatype=bøker">https://www.nb.no/search?q=oaiid:"oai:nb.bibsys.no:999919995985802202"&#38;mediatype=bøker</a>.</div>;
<div class="csl-entry">Nyhus, Ingfrid Breie. 2019a. «Tradisjoner på spill - Riss av et univers». <i>Norwegian Academy of Music</i>, nr. 1 (juni). <a href="https://www.researchcatalogue.net/view/385124/398166">https://www.researchcatalogue.net/view/385124/398166</a>.</div>;
<div class="csl-entry">———. 2019b. «Tradisjoner på spill - Det abstrakte i folkekunsten: Sammenstillinger». <i>Norwegian Academy of Music</i>, nr. 1 (juni). <a href="https://www.researchcatalogue.net/view/385124/398718">https://www.researchcatalogue.net/view/385124/398718</a>.</div>;
<div class="csl-entry">———. 2019c. «Tradisjoner på spill - En folkemusikalsk estetikk». <i>Norwegian Academy of Music</i>, nr. 1 (juni). <a href="https://www.researchcatalogue.net/view/385124/398627">https://www.researchcatalogue.net/view/385124/398627</a>.</div>;
<div class="csl-entry">———. 2019d. «Tradisjoner på spill - Maske». <i>Norwegian Academy of Music</i>, nr. 1 (juni). <a href="https://www.researchcatalogue.net/view/385124/398439">https://www.researchcatalogue.net/view/385124/398439</a>.</div>;
<div class="csl-entry">———. 2019e. «Tradisjoner på spill - Samtale om Avstandsriss». <i>Norwegian Academy of Music</i>, nr. 1 (juni). <a href="https://www.researchcatalogue.net/view/385124/398388">https://www.researchcatalogue.net/view/385124/398388</a>.</div>;
<div class="csl-entry">———. 2019f. «Tradisjoner på spill - Tri vendor yver elvi». <i>Norwegian Academy of Music</i>, nr. 1 (juni). <a href="https://www.researchcatalogue.net/view/385124/398423">https://www.researchcatalogue.net/view/385124/398423</a>.</div>;
<div class="csl-entry">———. 2019g. «Tradisjoner på spill - Utkast». <i>Norwegian Academy of Music</i>, nr. 1 (juni). <a href="https://www.researchcatalogue.net/view/385124/398213">https://www.researchcatalogue.net/view/385124/398213</a>.</div>;
</div>


Kind regards,
Masters student
  • edited yesterday at 4:08pm

    It's usually encoded like this:

    div class="csl-bib-body"


    <div class="csl-entry">Askeland, Norunn, og Magdalena Agdestein. 2019. Metaforer: hva, hvor og hvorfor?/i Oslo: Universitetsforlaget. <a href="https://www.nb.no/search?q=oaiid:"oai:nb.bibsys.no:999919995985802202"&#38;mediatype=bøker"https://www.nb.no/search?q=oaiid:"oai:nb.bibsys.no:999919995985802202"&#38;mediatype=bøker/a./di


    how do I remove these </> codes when they do not work in google docs?
  • You're saying you're seeing this HTML code directly in Google Docs, after using Add/Edit Bibliography?

    If you erase the bibliography and try again, does the same thing happen?

    If so, can you provide a Debug ID from Zotero for that happening?

    Does it happen if you use File → Make a Copy and try in the new document?
  • Yes, I see only the HTML code, it's all linked as a blue link.
    It also happens in a copy of the document.
    It also happens when I erase and try again.

    Debug ID: D1254690126
  • @adomasven will need to look at this. I don't recall our seeing this before.
  • @affa what citation style are you using?
  • I've tried with both APA 7th edition and Chicago Manual of Style 17 (author-date).
  • Does this happen in a new document for you? Do you have other Google Docs plugins installed?
  • edited yesterday at 4:09pm
    In a test document, this problem actually does not occur; then everything displays as it should.

    I'm just using the zotero addon, nothing else is installed.
  • If you remove everything but a few pages from the document does it still occur? Do you have suggestions on the document?
  • edited yesterday at 4:09pm
    Yes, still occurs with only a few pages, and even just with a single citation in use. There are no suggestions in the document
  • Could you share a copy of a document where you can reproduce this with support@zotero.org?
  • edited yesterday at 3:24pm
    @affa I looked at the document and it seems that there is a bug in Zotero that breaks citation insertion when there are quotation marks in the URL field of an item being cited. In your case it's the "Askeland, Norunn, og Magdalena Agdestein. 2019" and possibly others. We'll fix this on our end, but in the meantime you can avoid this issue by going into Zotero and changing the "URL" metadata field of the item causing the problem.
  • edited yesterday at 3:56pm
    @adomasven

    Thank you for your effort and help!
    I changed the URL in mentioned citation, and the bibliography worked immediately.

    Great work, great help!
Sign In or Register to comment.