Second initials of editors not showing

edited 12 days ago
In my bibliography, the second initials of editors of books are not showing.

In this reference below 'Rodewald, P.' should be showing as 'Rodewald, P. G.'.

Jackson, J. A. & Ouellet, H. R. 2020. Downy Woodpecker (Dryobates pubescens), version 1.0, in Rodewald, P. (ed.) Birds of the World. Cornell Lab of Ornithology, Ithaca, NY, USA.

I believe the code below from my csl file is causing the second initial not to show. Anybody spot what is causing the second initial not to show?

<macro name="secondary-contributors">
<choose>
<if type="chapter paper-conference" match="none">
<names variable="editor translator" delimiter=". ">
<label form="short" prefix=" (" suffix=")" plural="never"/>
<name initialize-with=". " and="symbol" delimiter=", "/>
</names>
</if>
</choose>
</macro>
<macro name="container-contributors">
<choose>
<if type="chapter paper-conference" match="any">
<text macro="container-prefix" suffix=" " prefix=", "/>
<group delimiter=", ">
<names variable="container-author" delimiter=", ">
<label form="short" prefix=" (" suffix=")" plural="never"/>
</names>
<names variable="editor translator" delimiter=", ">
<name and="symbol" delimiter-precedes-last="never" initialize-with=". " name-as-sort-order="all"/>
<label form="short" prefix=" (" suffix=")" plural="never"/>
</names>
</group>
</if>
</choose>
</macro>
  • I can't see your code (you'd need to put it betwee <code></code> tags to be visible) but it's definitely not your CSL: CSL has no setting to only show one initial. I'd guess it's a metadata issue. Look at the item in Zotero itself, make sure you see both names or initials there, then create a bibliography for that item directly in Zotero to test.
  • Thanks for quick reply. It was a metadata issue and now sorted.
Sign In or Register to comment.