Issues with syncing

I added files to Zotero on my desktop PC and tried syncing them. I did not receive any error messages, but the files are not syncing to my tablet or to my web library.
I am not sure whether I am posting this to the right place because I have never had a problem with Zotero before.

Debug ID: D89293352
  • It's not clear whether you're referring to items or files, but see one of these pages:

    https://www.zotero.org/support/kb/changes_not_syncing
    https://www.zotero.org/support/kb/files_not_syncing
  • Nothing is syncing... No changes I make are syncing past a certain point and it is becoming a huge issue. No one is responding to my emails for support. I really need help. My work is inhibited by this and I pay a lot of money for storage every year. Can someone please help me?
  • edited 13 days ago
    This is where support happens, not via email. We're happy to help you, but you need to actually read the information we provide and provide the requested information. Both of the linked pages walk you through how to debug this and explain what information we'd need to help you further.

    I have no idea why you would send us an email that says "The forum has not been helpful" when you didn't respond to my post in over 24 hours and didn't provide any of the requested information that would let us help you.
  • None of those things are applicable by the way. I have already read those. That's why I am here. I got to step six, which is contact Zotero support. So please help me figure this out.
  • This is Zotero support, but there is literally no way we can help you further if you don't provide the information we ask for on those pages.
  • What information are you asking for? I already explained the problem. For the following link: https://www.zotero.org/support/kb/changes_not_syncing
    (1) I am not looking in the wrong place. The only place where any of the files and items appear that I uploaded the other day is my one PC. It does not show up on my tablet or online, and I have the exact same folder selected.
    (2) The syncing process is "complete" but none of my items synced. Says it was last synced 3 minutes ago
    (3) I already said I do not have an error
    (4) The library is set to sync. I already checked that.
    (5) It is the same account. Everything else is there except for the items I added the other day. It's like it just randomly stopped syncing the other day.
    (6) Here I am at step six. I posted a Debug ID.

    For the following link: https://www.zotero.org/support/kb/changes_not_syncing
    Not applicable because I have no error message.

    So what information are you asking for? I don't get it.
  • The page explains that, if the data isn't showing up online, the problem is on the computer where you're creating the data, and that the Debug ID needs to show you making a change locally that isn't uploaded. The Debug ID you provided just shows a successful sync with no local or remote changes.

    But your online library shows dozens of items added yesterday, so I'm still not sure what you're saying is missing.
  • Is there any way to post a screenshot so you can see what I am seeing? I made 68 changes that are not syncing. The folder in question has 26 items in it. It is supposed to have 94. The only place where 94 items show up in this folder is on my PC. These 68 changes are not syncing to my tablet or to the web library.
  • edited 13 days ago
    Yes, you can upload a screenshot somewhere (e.g., Dropbox or Google Drive) and post a link here, or send it via email if you don't want to share it publicly. But we'll respond here.
  • edited 13 days ago
    We still need the Debug ID, though — and you need to check whether the item is synced when you make a local change. Start debug output logging, make a change to an item in the collection locally that's not in the collection online, sync, submit the logging output, and post the Debug ID here, and also let us know if the change appears online.
  • I already posted a debug ID, though. I will post one again, but you just said it doesn't show anything.
  • Here is one again after trying to sync again. D671592677
  • No, I said you didn't follow the instructions, which ask for a Debug ID that includes a local change that doesn't show up online. And the one you just provided doesn't either. Please carefully read what I wrote in my last message and provide that.
  • I am trying to follow your instructions. I made a change. I changed a title to sentence case for an item that is not in the web library. Then I synced and the 68 items are still not there. The item I changed is still not there. D651932805
  • I figured it out. The folders don't work the same way on the web library and on my tablet as they do on the desktop app for whatever reason. When I click the folder I showed in my screenshot, all items show up on my desktop, including the items in the subfolders. This is not the case on my tablet and the web library. I am not sure why this is, but the issue is resolved.
  • edited 12 days ago
    There is an optional setting on desktop that triggers this behaviour under "View -> Show Items from subcollections" menu (it's off by default). Web Library does not offer this functionality.
Sign In or Register to comment.