Zotero PubMed Connector not working for citations from today's JAMA

edited 8 days ago
The connector has been working well but suddenly today, after downloading a first citation, subsequent journal articles are not downloading. I've tried several different references cleared all cookies and files, restarted the browser and Zotero and none of these things solved the issue. An example page is here: https://pubmed.ncbi.nlm.nih.gov/33595634/
I saved a debug from one try: Debug ID D371980371
  • It was recently reported that records that were created within the last 24 hours may not be accessible through NCBI's API, which means the translator may not have access to them.

    https://forums.zotero.org/discussion/comment/373741/#Comment_373741

    This entry appears to be brand new. Can you wait until tomorrow to add it? Or import it by downloading the nbib file from that page (via Send to -> Citation Manageer)?
  • Ah ha -- got it. Thanks.
  • @dstillman @adomasven -- since people seem to be using .nbib more with the new interface (and since it's _almost_ equivalent to the XML), could we have the connector (offer to) intercept and import the files as it does for RIS and BibTeX? They're served as application/nbib
    I think that'd be a nice, and presumably pretty easy, enhancement.
Sign In or Register to comment.