Error updating citations in shared Google Doc

Zotero was working in a shared google doc yesterday. "Suggesting" edits setting is not on. Yesterday another user was doing suggested edits and the zotero in-text citations were working. Today, Zotero is not working with google docs. I am logged into the same user name attached and linked to Zotero. When I use an unshared google doc things work fine. Could there be a security issue?

Debug ID: D2072321516

Here are the steps I take: set cursor in doc where I want in-text citation > click Zotero tab > add/edit citation> Zotero pop-up bar > type in author name, select > enter>
I get the pop-up "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"
I can click yes or no. I click 'yes', follow direction and no luck.
Then when I click 'no', the {Updating} link will take the place of an in-text citations but will never update. Clicking on the {Updating} link, I get this error:

TypeError: Cannot use instanceof on a non-object.
at Code (Zotero Google Docs Integration):815 (iterateSection)
at Code (Zotero Google Docs Integration):839
at Code (Zotero Google Docs Integration):825 (iterateSection)
at Code (Zotero Google Docs Integration):924 (iterateSections)
at Code (Zotero Google Docs Integration):814 (getAllLinks)
at Code (Zotero Google Docs Integration):114 (getFields)
at Code (Zotero Google Docs Integration):414
at Code (Zotero Google Docs Integration):75 (callMethod)

I have uninstalled and reinstalled Zotero Connector, Chrome, and Zotero desktop version. I am using Windows 10. I always restart chrome and Zotero after reinstalling.
  • edited February 9, 2021
    (3)(+0000755): Exception in Document.getFields
    Does this still happen if you restart your browser and Zotero? Sorry, you said you've done this. @adomasven will need to take a look.

    Does it happen if you make a copy of the document (via File → Make a Copy)?
  • @dstillman yes it still occurs. I have restarted browser and Zotero several times and restarted my computer. When I created a copy of the document it worked, but the copy is not shared with anyone. I have to have this document shared, unfortunately.
  • It's almost certainly not the sharing itself that's breaking it, so you might be able to just share the copy and move forward with that one. But if you want to wait, Adomas may be able to say more about the original document.
  • Just tried something else,... I made two copies of the document. One with and one without the "Copy comments and suggestions" selected in google docs.
    The copy with comments and suggestions still provides the same errors as the initial issue.
    The copy without comments and suggestions allows Zotero to work fine.
  • If you could follow the step 10 of debugging broken documents instructions and isolate a small portion of the document that causes the error please share it with Otherwise you'll need to figure out which comments or suggestions cause the error and resolve them before continuing.
  • @adomasven I isolated the suggested text that is causing the error. It worked. Hope this doesn't continue happening... Fingers crossed!
  • edited February 9, 2021
    If you can reproduce this in an excerpt in a copy of the document, would you mind sending a share link to with a link to this thread so that we can see if we can fix it?
  • @lexi_GC Ok we have pushed a fix for this error for the Zotero Connector Beta. Could you try testing that version and confirming that you can update your documents properly now?
  • @adomasven Yes, I emailed back the errors.
  • Did you install the Zotero Connector Beta? It is only available for Firefox, but the Debug ID you have sent us is from Google Chrome. Also please post all troubleshooting information here. The email address is only for sending us private information.
Sign In or Register to comment.