Zotero does not recognize old references

I'm working on a shared document. Zotero does not recognize the references created by my colleague who originated the document and references. Instead, the added references I am adding are beginning from 1 half way through the document. Please advise.
  • What writing software are you using? Did your colleague use Zotero to insert their citations?
  • we are using MS Word. my colleague used Zotero to insert citations.
  • See the linked page, which explains how this would happen.
  • Thanks very much @dstillman. It looks like my document is no longer active. This is the back story....

    I've hired someone to insert references and create a bibliography. She included me in a group and sent me the document as an email attachment. I downloaded Zotero, registered and took steps in the 'edit/preferences' tab as suggested in the tutorial. The word document is saved as a .doc Word document.

    The bibliography is not grey which means something has indeed happened. Question is whether there is something she needs to do on her end or something I'm not doing on my end.

    Thanks again for any guidance on this.

  • The document needs to be saved as .docx, not .doc
  • Thanks much @bwiernik! I just tried saving it as .docx and the same problem transpires. Thanks for any advice.
  • edited February 11, 2021
    I mean that a document with live citations would need to be saved as .docx. If the citations are already flattened in your document, there is no way to recover them. You would need to ask your research assistant to send a new copy with live citations saved in .docx format.

    (The citations are using a built in feature of Word--fields--the same feature that is used for automatic tables of contents, figure captions, etc. This feature is not supported by older formats or other programs such as Apple Pages or Google Docs, so you need to be sure to not open the file in those programs to preserve the live fields.)

    If you like, you can post the original document you received from your assistant to Dropbox or similar and give a link here. I can check if the document has live citations in it. If you can't do that publicly, you could email to support@zotero.org with a link to this thread.
  • Thanks again @bwiernik. We are not using google docs, apple pages, etc. She saved the doc as .docx file. Unfortunately, it came dead on arrival. Literally, the citations were flattened. She sent the citations separately without the document and they were alive. odd. So, i tried copy and pasting but that didn't work of course. Is the problem on her end or my end? or both? I'm sure it's something small that we are not seeing.
    thanks again for taking the time. Wish there were someone to speak with.
  • edited February 12, 2021
    Wish there were someone to speak with.
    I'm not sure what you mean by this — you're speaking to us, and we're explaining the issue. See How Zotero Support Works.

    But this is not a Zotero issue. Again, Zotero citations are standard Word fields, the same as all the things bwiernik lists above. Someone saved your file in the wrong format or with the wrong tool. Saving from Word as a .docx doesn't cause this — that would be a catastrophic Word bug, and it doesn't happen. So if she did save it that way, it was already broken before that.

    You'll need to restore to a version of the document that still had live fields.
  • Thanks again for responding, @dstillman. I just spoke to my research asst on the phone. On her end the fields are active (numbers are grey). When she sends it as an email attachment, the fields go flat. We are merely passing a word document as email attachments and not using other programs.

    How can it be active on her PC and inactive as soon as i open it. I am new at this so there could be something I'm missing.

    Thanks for any advice.
  • And just to make sure -- she's also working in Word, right? Saving from LibreOffice to .docx would flatten citations.

    If you're definitely both using Word, let's make sure the fields are actually not recognized (how fields are displayed is a Word setting, so that may not look the same for you). What happens if you open the document and immediately after receiving it, click on "Document Preferences" and select a different citation style, e.g. Chicago (author-date) which would turn the citations into in-text author-date if they're still active?
  • yes, we are both using word.

    Whether I use Chicago or Vancouver (superscript), it doesn't recognize the 109 citations in the document. Zotero works and a citation appears, but it is creating a new set of citations.

    a mystery
  • When she sent the citations without the narrative, the citations appeared grey.

    Is the problem on my end or on her end?

    How do I invite her on this discussion?

    Please advise.
  • If you're able to share the document, she can email it to support@zotero.org with a link to this thread and we can take a look.

    Not sure what you mean by "narrative", but if she can send both versions, that might be helpful.
  • I copy and saved the narrative without the cover page on a new document. The references came alive. The numbers are shaded in grey, in the bibliography. nonetheless, the numbers are not continuous. Also the first number is missing. It begins with number two. I'm using vancouver superscript.
  • edited February 13, 2021
    The document you sent doesn't contain any active Zotero citations or bibliographies.
  • @VMagar: Neither of the documents your colleague sent via email contain active Zotero citations either.

    You need to go back to a version of the document where the citations are live — where you can click Refresh in the Zotero toolbar and it does not say "You must insert a citation before performing this operation." If it says that, the citations are already flattened.
  • Thank you so much for your response. What is the best way to recover or "unflatten" the citations? I have tried updating my zotero, saving the document as in the .docx format and syncing the document with the zotero, but nothing seems to fix the issue. Thank you so much!
  • edited February 14, 2021
    You can't. From Existing Citations Not Detected, linked at the beginning of this thread:
    If you find that your citations have been flattened, your only options are to restore the document from a backup, re-insert the citations using the plugin, or manually edit the document's citations and bibliography going forward. If reinserting citations, it may help to adjust Word field settings to always highlight fields in gray rather than only doing so when they are selected.
    And just to be totally clear, this is not something Zotero did. This is something you (or someone else who worked with the document) did by saving the Word document in the wrong format or with the wrong tool or by using Unlink Citations. Once that's happened, there's no way to recover the active citations in the document.
  • edited February 15, 2021
    @arohan, @VMagar: You'll need to post any questions you have here, not via email, if you want them addressed. The email address is solely for sending files and other private info.

    @arohan, the document you sent has only one active Zotero citation and a Zotero bibliography. A Zotero bibliography is simply a reflection of the citations in the document as of the last Zotero operation — if you right-click on it and click Toggle Field Codes, you can see that all it is under the hood is ADDIN ZOTERO_BIBL {"uncited":[],"omitted":[],"custom":[]} CSL_BIBLIOGRAPHY. So when you click Refresh, the formatted text of the bibliography is reduced to the one active citation still remaining in the document.

    I'm afraid there is only one answer we can give you here, and it's the same one we've been giving from the beginning: you need to restore to a version of the document from before the citations — not the bibliography — were flattened. Since the version you sent still has an active bibliography, it means that whatever happened happened between the last time you used Zotero in the document and when that version was saved.
Sign In or Register to comment.