Citations automatically unlinked using google docs/firefox

Hi! I've come into a problem writing my thesis this morning. I tried to change the bibliography style and zotero unlinked all my citations. ctrl+z did nothing so I restored a previous version of the document, but then the problem doesn't seem to have been solved as any change I makeI juste have the "unlinked citations" pop-up again.

Report ID: 1095960005
Steps to reproduce it:
1. Open document that already has citations and bibliography
2. Open document preferences and change bibliography style
3. Pop-up appears telling me that all my citations have been unlinked.
4. Restore previous document version
5. Make any change (add citation, change style etc) and the problem is still there.

Funny thing is, I opened a new document, wrote some paragraphs, added citations and changed bibliography style with no problem. It just happens with the thesis document and any copy I make of it.

Thanks for reading, I hope you can help me!
  • Thanks for answering, but yes I saw that earlier, but I already use Firefox with the 5.0.81 version of zotero connector ... I tried to use Opera and Chrome but I encountered the exact same problem. I couldn't reproduce this error with a new document.
  • Yeah, that other thread is unrelated. @adomasven will need to look at this.

    Are you able to share a copy of the document, or a small excerpt of it that still triggers the problem, from before this happens? If so, can you send a share link to with a link to this thread?
  • Thank you dstillman, I just send the mail to support so I'll wait for their answer.
    Have a nice day!
  • (There's no "they" — we'll help you here. That address is just for sending private info.)

    We can modify that copy as necessary?
  • Oh sorry, I didn't understand properly!
    Yeah I made sure that the share settings were correct and this is a copy so do whatever you have to!
  • @nimrauko You'll need to go further back in the document history for that. Zotero only detects unlinked citations when you interact with the plugin, like attempting to add a citation or similar. You should look back through the history to see whether something unexpected didn't happen to the portion of the doc that has that problem, such as accidentally copying and pasting it, or moving the text by dragging and restore to that version.
  • @adomasven I found the latest version where all my citations are still linked. I can't find what I could have done that's unusual.. I don't think I moved text by dragging (cut/copy to another document yes but dragging no).
    Should i send you a copy of this version?
  • By "linked" I do not mean that the Zotero citations are still black (not red for unlinked), but where performing a Zotero operation (even opening the doc prefs window) does not lead to them turning red (unlinked). If that's true for a version of the document you'll need to see what edits happened to it since. A copy of the doc in this case won't help because a document copy does not contain its revision history.

    If you cut and pasted to from/to another document, that could have very well have been the cause of the citation unlinking. If you did it without the Zotero Connector installed that's a definite. If not, it may have been due to a bug with the Zotero Connector that we haven't discovered yet.
  • I found a version where I can edit citations without them becoming unlinked. I cut/pasted text from this document to another but there wasn't any citation in it so I still don't understand. The connector is installed on all my browsers since even before starting this work.
    I have no idea about how this happened.
    Luckily that last version is pretty recent and I don't have a lot of citations to relink by hand so I think I will work with that. I just hoped you'd find a solution for someone who had less luck...
    Thank you for your help.
  • Ok, so the Google Docs version history should allow you to see a change to either the whole document, or just Zotero citations at some point between the last version the citations are linked in and unlinked. If you can identify that action and reproduce it, we will look into it since that would be a bug. Otherwise this isn't enough information for us to attempt debugging the issue.
  • I'm having the same problem.....when I move text with a citation from one part of my document to the other the citations do not update. I'm using Google Chrome and Google Docs. Is there are fix to this?
  • @mblock: We're not able to detect drag-and-drop in Google Docs in order to preserve citations. As long as you have the Zotero Connector installed, cut/paste should work.
  • Got it. Thanks
Sign In or Register to comment.