Google docs citations stuck on "Updating"

Plenty of Gdocs problems listed, but have not seen this one.

This happens both on my Windows 10 machine with Zotero desktop, and on my Chromebook running Linux desktop version with crouton.

I put in the citation, and it all works as designed, but then instead of the correct reference, it inserts a link that says "Updating". Before it does that, I sometimes see the appropriate reference pop up for a second before going to "Updating." It inserts the references appropriately in the bibliography.

Clicking on "Updating" link a dialogue opens which says:
"You have modified this citation since Zotero generated it. Editing will clear your modifications. Do you want to continue?
Original: (Dworkin, 1993; Eimer & Schlaghecken, 2003; Gibbons, 2009; Schulkin, 2004; Sterling, 2004)
Modified: {Updating}"
I click "yes" to update and I am taken to the Quick Format Citation box, which is filled in with all the references.
I click enter to enter the citations in the doc, and again I get "Update".

Sometimes after going through this 3 or 4 times, it will finally enter the citations correctly.
  • I am new to Zotero but this is happening to me as well on my mac, using Google Docs through Chrome. It seems to work normally if I go through editing the citation a few times, same as what you've described.
    Anyone have any advice?
  • @aarwdc @taeven Could you try the Zotero Connector Beta and see if it is fixed there?
  • Same for me!! And also my references unlinks a lot of time!!
  • adomasven:
    On my chromebook I downloaded and extracted the Beta connector, but not sure how or if I install it into my linux desktop app or if it is installed to chrome. Haven't tried windows yet, either.
  • adomasven:
    Answered my own question when I did the windows install --- it is is a whole new fresh install of zotero.

    Yes, it seemed to fix the problem with Google Docs citations on 6 trails. It was intermittant, so I cannot say 100% it is fixed, but it certainly seems to be.

    A question though. Is my Zotero now on a continual beta track, or will the next update, which I assume will include this fix, bring me back to the non-beta track?

  • Same problem, just over the past few days. It's driving me up the wall! I have to restart Zotero AND re-fresh my google doc in between every single citation I want to add. So, it takes a good 2 minutes per citation. This is even happening in small docs with few citations. I've updated my Google Chrome. I already have the Zotero extension (and it updates automatically). Hopefully some kind soul can find a solution to this horrible bug! It's making Zotero non-usable.
  • @anadea: There's a beta version of the connector for Firefox, linked above by Adomas, that we're hoping fixes this. If you have Firefox installed, you can try that now. We'll hoping to release that for everyone within the next couple days.

    @aarwdc: You can switch back to the main version of the Firefox extension once this is released. We'll post here when that's the case.
  • This is still an issue for and Firefox Connector 5.0.86. It doesn't happen for me in Google Chrome but I do not want to use that browser if I don't have to.
  • I have replicated the error and might have found a potential reason for this glitch.
    My System - ChromeOS, with Zotero installed in a Linux Container, Debian 11, 5.10.92-14532-g179c52887ab5

    I deleted the linux container and reinstalled it, then I installed a clean Zotero. It ran beautifully without an issue, and then I downloaded a 'linked' file into Microsoft Office, logged off the computer, resumed and returned to the original document in Google docs. I attempted to add another citation and ran into the update error. It seems to be an issue with the Zotero connector. (Chrome browser, Version 99.0.4844.57 (Official Build) (64-bit)
    Zotero Linex version

    These are the errors... I had a pop up message indicating that this Google account didn't have permission to edit .. or something .. I can't recall the exact phrase.

    When I went into Zotero and tried to get a software update, I ran into another issue, but I believe the two are connected.

    "A recommended update is available, but you do not have permission to install it. To update automatically, modify the Zotero program directory to be writeable by your user account."

Sign In or Register to comment.