No sign of zotero in Word or Open Office

Hi everybody,

I just installed the new firefox extensions for Word and Open Office Zotero 2.0b7 plugins on a Mac 10.6.1 machine. I am using Word 08 and Open Office 3.1.1. Unlike the previous versions, I am seeing no sign of the zotero plugin in Apple Script menu (and the relevant User Data directory) and the Open Office Extension Manager. Did I miss something? Was I supposed to also place the extension files (.oxt or .dot or whatever) manually into relevant places (as we used to do with previous versions).

I'd be happy to elaborate if necessary..

  • looks like you're installing the wrong plugin.
    is the right one.
  • edited September 15, 2009
    Nope, that is exactly the add-on I installed on Firefox. I reinstalled and triple-checked.

    The .xpi file is a Mozilla extension installer zip file, and I assume it is supposed to write a plugin to my relevant Office user directory. I have the correct add-on installed in Firefox, but no plugins appear in either Office.
  • I'm having a similar issue. I'm running FF 3.5, Word 2008, on OS X 1.4.11.

    All of the FireFox plugins install just fine, but when I go to the the AppleScript menu in Word, Zotero's nowhere to be found. It's not in the User Data directory either.

    I've tried a fresh install of FireFox, reinstalling all plugins, choosing "reinstall Word components" from the Preferences button for the integration plugin, etc. Nada.

    Any suggestions?
  • Just an update: at home I'm running OS X 10.6.1. Word integration works beautifully there. For me, at least, the issue is particular to Tiger.
  • edited September 15, 2009
    First, make sure you have the latest MacWord plug-in. We just released 3.0a2, which may fix your issues.

    If this doesn't help, try opening your Firefox profile folder, then navigate to extensions/ Open "install.applescript" (should open in Script Editor), and then click "Run" at the top of the window. This may install the scripts for you, or you may see an error message. Either way, let us know how it goes so we can try to improve this process for other users.
  • Thanks, Simon! I'll give that I try when I'm back in the office tomorrow, and let you know what happens.
  • I updated to 3.0.a2 from 3.0.a1. I first got an error in Firefox saying "MS Word Integration error", also saying that Firefox will attempt to fix it if I restart. Which I did, and that fixed the integration problem.
    Thanks for the fast pace of updates and development of zotero and plugins.

    Obviously, I still have the Open Office integration problem. Should I just manually import into Open Office the "Zotero_OpenOffice_Integration.oxt" file from ~/Library/Application Support/Firefox/Profiles/up61ptm5.default/extensions/, or is there a way to cajole Firefox into doing that for me?
  • enozkan, try going to Tools->Add-ons->Extensions, clicking "Preferences" for Zotero OpenOffice Integration, and then clicking "Re-install OpenOffice Components." This should work, but if it doesn't, you should also be able to install the oxt file manually.
  • edited September 15, 2009
    Thanks Simon, that solved the Open Office integration problem.

  • Simon, I tried the steps you suggested. I updated the plugin, but nothing showed up in Word. Running the script yielded the following: "Neither Word 2004 nor Word 2008 appear to be installed on this computer. Please install Word, then try again."

    I tried uninstalling and reinstalling the plugin, with the same result. Word 2008 is installed.
  • @SImon: the reinstall UI needs work. First, the "reinstall OpenOffice components" text is a little vague. I'd prefer if it said "reinstall Zotero OpenOffice plugin".

    Second, there's no progress information, so appears that it freezes (and AFAIK, maybe it does).
  • Another issue: the installation process is too confusing, and users are forced to wade through a bunch of content to figure out what to install.

    Can you not have the links in one clear, consistent, location? Maybe it's just a little table on the front-page with platform, word-processor, and version?

    Finally, isn't it time to declare 2.0 final and deprecate (at least from the main home page) 1.0?

    Simplify please.
  • Bruce: At the moment much of the information on the plugin installation page, particularly for the new plugins, is quite necessary. Once it's not, we'll simplify.
    the installation process is too confusing
    Part of the point of the new plugins is that they're single-click installs into Firefox, and they do the rest automatically. When it works, you shouldn't have to do anything else. When it doesn't is what we're working on now, and why they're not on the front page.
    Finally, isn't it time to declare 2.0 final and deprecate (at least from the main home page) 1.0?
    No. But we're feature-frozen from now until 2.0 Final.
  • Just to clarify my "too confusing" point:

    It's not a problem for me. It is a problem for many of the students I am asking to use Zotero, who have varying comfort levels with this technology.
  • After verifying that the plugin works with Office 2004, I uninstalled 2004 and did a fresh install of Office 2008. I then reinstalled the plugin for MacWord integration. I got the same result: "Neither Word 2004 nor Word 2008 appear to be installed on this computer. Please install Word, then try again."

    I get this error whether I try to install from the preferences option in the add-ons window or from the directory, as Simon describes above.

    Perhaps this is an issue with OS X 10.4.11? Everything installed without incident on my home machine running 10.6.1.
  • edited September 16, 2009
    acavender, that's an interesting issue, probably related to having just installed Office 2008. We've put a workaround into our dev version, but it should still be possible to get things to work for you. First, try opening Word, restarting the computer, then reinstalling the Word components. If you still get an error, open a terminal window (/Applications/Utilities/ and type the following

    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -r /Applications/Microsoft\ Office\ 2008

    and reinstall the Word components again.
  • Thanks Simon. No dice, unfortunately. I'm still getting the same error, even after trying both of these things.

    I suspect my best solution for now is to downgrade to Word 2004 at work, since documents with Zotero citations seem to work just fine in both 2004 and 2008.
  • edited September 16, 2009
    acavender, if you click this stupidly long link, let Firefox open it in Script Editor, and then click "Run" at the top of the window, things should work for you in Office 2008.

    EDIT: Link was mangled by the forum software. Copy and paste the following into your address bar
  • Simon--many thanks! That did it. :)

    Just out of curiosity--is this an issue with Tiger? I'm curious, as I'm asking my students to set up Zotero and join a group in the next couple of days.

    Just to be on the safe side, I've saved the script in case they run into trouble.
  • acavender, I'm not really sure what was causing the issue, but the next version of the MacWord plug-in will try another, more reliable method to determine if Word is installed before falling back on the current method.
  • hi i just had the same problem and tried the link Simon posted.. But when i ran it the error window pops up "Syntax Error: a unknown token can't go after this identifier".
    What am I supposed to do?
  • edited September 16, 2009
    I just did the update from Open Office Integration 3.0.a1 to a2. It seems to have gone through fine on the Firefox end (no errors), but the Open Office Extension Manager says I have 3.0.a1. I deleted the extension both in OOo and Firefox, and installed a2 fresh, but I still get the version number 3.0.a1 on OOo.

    Is this just a version error thing, or am I really getting 3.0.a1 despite the update?
  • On a similar note, how can I know that Word Integration plug-in really updated? I don't know much about AppleScript, a way to check I am truly updating the zotero scripts in Word might give some confirmation...
  • We didn't update the version on the OOo oxt file because it didn't need any changes, although I now realize that might produce some confusion. All of the integration code now resides in Firefox; the extensions/scripts in Word/OOo are just very small stubs to call that code. If integration is working at all, then these stubs are working and you shouldn't worry about their versions.
  • Thanks Simon, I will stop worrying and love the code.
  • I had a hugely similar problem, but mine was not solved with any of the applescript or reloading of the word components. When I do the applescript link, I get a very long error message that at the top says AppleScript Error and then below are all these data errors within word script menu denying permission. Please help. Paper is due on Monday.
  • If you're using Word 2008, try deleting Documents/Microsoft User Data/Word Script Menu Items/Zotero. Alternatively, try repairing permissions on your hard drive. If that doesn't work, post the whole error message you get upon install here.
Sign In or Register to comment.