Google Docs Problems

Have been having a problem adding citations/bibliographies on Google Docs since earlier today, and while I thought it was a problem with my account/laptop, I've since been talking to a classmate with the same problem.

While Zotero is still working as a Chrome extension and allowing me to link citations to my Zotero desktop library and Google Docs still has the Zotero button at the toolbar and will recognise citations when I hover over them, like I said, it won't let me do anything beyond that.

When I click on "Add Citation," it was initially trying to link/sync with my Zotero desktop - the window would pop up where I'd usually select the Gmail account. However, after almost 5 minutes, the loading window would crash and continued to do so every time after. I tried a lot of troubleshooting based on these forums - closed app and Google Doc, signed out, deleted and re-installed extension - and nothing has worked. The only difference is that the window no longer pops up - instead, Google Docs now says "Saving Changes" but nothing else happens.

I'm at my wits end, and while I thought it was a problem on my end, I'm finding it strange that a classmate is experiencing the exact same problem at the exact same time. Is this a problem on Zotero's end or does anyone have any recommendations on my end for fixing this?

Thanks in advance!
  • What you've described sounds like a Google services issue. Is it still broken for you today? Could you submit a Report ID from the Connector?
Sign In or Register to comment.