Fail to add bibliography in a large document

Hi, I am writting my thesis (around 300 pages) and I tried to add a bibliography using zotero (in Word). It doesn't work and I get an error message. Would someone know how to deal with that? Thanks in advance and have a lovely day.
  • What does the error message say?
  • Hi, thanks for your reply. If I remember correctly it only says that there has been an error.
  • Could you try again -- we need the exact error message as well as an error report ID from Zotero:
    https://www.zotero.org/support/reporting_problems
  • No problem. Ok, if I click on « add/edit bibliography », I wait like two minutes and then it appears only that {Citation} where the biblio is supposed to be... and nothing else... then an error message appears « zotero has encountered an error while updating your document » (I translate from French). There is no ID...
  • You can always create an error report ID from Zotero -- see the link above.
  • Sorry... I didn’t know that... here the id: 1304808926
  • @adomasven -- anything useful in the error report?
  • There's various errors in the log indicating timeouts. Does it help if you switch to English language on the macOS, at least temporarily? We've recently seen a surge of issues with macOS Word integration which seems to be caused by recent OS or Word updates and are trying to figure out how to fix them. Some users fix it by switching to english language, but it's not clear whether their issues and yours are related. How old is the Mac you're working with?
  • Hi, I have to test it tomorrow. I thought it might be because I have more than 1100 footnotes... I’ll keep you informed tomorrow. Thanks for your help and support.
  • My macbook is quite new... from 2017.
  • I’ve tried to create a bibliography in a new document with only four footnotes and it worked.
  • edited 11 days ago
    While this shouldn't be a reason for updates to fail completely, documents of such sizes usually pose issues at the very least with time required to update. We've also recently found indications that there might be severe issues with the macOS App Nap feature, which stops programs from using a lot of CPU time when not directly on user's screen. Next time you attempt to insert the bibliography make sure that both Word and Zotero are visible on screen for the operation.
  • Ok, thanks for your help. I will try again tomorrow and I keep you informed.
  • Hi again, I tried again to create the bibliography by having both Zotero and Word on the same screen and nothing else opened. I also updated Word with the very last version but the error keeps coming. Here the new error report ID: 1560389380. Thanks for your help and assistance.
  • How long did the operation run for before you got the error message? Could you produce a Debug ID from Zotero for a failing insert? Did you work with Word while the operation was running?
  • Hi, I would say for around 2-3 minutes. Here the Debug ID D1456526857. Yes, I work with Word. Hope it helps.
  • What Adomas meant was were you continuing to actively work with Word (e.g., typing elsewhere in the document) while the process was running?
  • Sorry... No, I wasn't. I normaly don't touch my document even while I am updating the footnotes because it takes already long enough to update as my document is large.
  • (by the way... I know it is not the current topic but it would be nice when you click "refresh" to know when the process is finished...if possible...)
  • If you cut the document to say 1/5th or 1/10th can you still reproduce the failure to insert the bibliography? Could you try to trim it down to the smallest document where you can still reproduce it and send it to support@zotero.org with a link to this thread?
  • Hi, I am testing that right now. Unfortunately, I cannot send you my document as it is an unpublished manuscript. I will do my best.
  • I've just sent you an e-mail.
  • edited 10 days ago
    If you cannot send us a doc excerpt where the problem is reproducible there's no need to send anything via email. We only use the email for private information. If you insert the bibliography into the document cut in half, and then paste back the original part of the document into it, can you successfully refresh (you may monitor the progress of the refresh by opening the Debug output view via Help -> Debug Output Logging -> View Log, we are working for a proper progress bar for that)? Otherwise you can try the debugging broken documents steps, and if that doesn't help it is likely that you will be able to insert a bibliography into this document with a Windows version of Word (even running on a VM on this computer if you know how to set that up).
  • Ok, I understand. I will work around it even if I am not sure to understand why I should trick it to be able to use it. Thanks for your help.
  • I will work around it even if I am not sure to understand why I should trick it to be able to use it. Thanks for your help.
    As I said, we've seen a recent surge of Zotero issues with Mac Word which we're unfortunately unable to debug due to their nebulous nature. There's a long history of Zotero issues with big documents on Mac Word that are out of our hands due to the limits of the tools provided by Microsoft for us to work with. Over the past 2 years those issues had disappeared and Mac Word integration had been working very well, but unfortunately a few months ago we've started getting reports of bugs from users such as yourself with documents of significant size that we are unable to reproduce.
  • edited 10 days ago
    @annevianin: What's the full, exact Word version here? You should make sure you're running the latest version.

    Note that you're also running macOS 10.14, which is two versions behind the latest version of macOS. While it's not very likely to help with this, if you're able to upgrade to Big Sur, that would be a thing to try. You should at least make sure you're running the latest version of 10.14.
Sign In or Register to comment.