Sync problem

I am doing some cataloguing on the zotero app. I have a problem with syncing I haven't noticed before. Usually, everything seemed to sync automatically. But today I noticed that some of the work I did yesterday had not been saved. After some testing I discovered the following pattern (what I am adding are manuscripts to a folder).

1. Leaving the platform (i.e. closing the app) does not save additions, when I am reopening it they are gone.
2. I have tried to save the work by syncing manually. Same result. After reopening the app additions have disappeared is gone.
3. However, for some strange reason the following works: I write my addition to the catalogue in folder X, open any other folder in Zotero, and reopen X. Then the addition is there also after Zotero has been closed and reopened.

I have also checked how what I do with he app relates to what I see in the web version of Zotero. Same pattern. I only get the changes visible in the web version if I follow the pattern in 3 (they show up immediately without reloading the page). 1 and 2 do not work.

As far as I can see there obviously is some problem here (at least the manual sync should work?). I don't think I have experienced this earlier, but perhaps I should start checking if something is missing. It may be significant that there was an update to the Zotero app being installed when I opened it today (my version is now 5.0.95).

Any suggestions about what I should do? Would it help to reinstall the app? I hope my explanations have been clear enough,
  • I'm not really sure what you mean here. Can you provide exact steps to reproduce the problem?
  • Thank you for your question. I am not sure how to explain this better. The changes I make are metadata to a manuscript I have created in a zotero folder using the zotero app (on windows 10). The problem is that the data I have added are not saved. This happens also if I use the sync up to the right. It seems to be syncing (rotating), but does not. This can be verified by closing and reopening the app (the changes have disappeared), but also by checking how the same item looks on the web page version of Zotero, no additions made in the app appear.

    The only way I currently can get additions I make saved are the way explained in 3. I open another folder and then reopen the folder I was working in. For some reason this makes the sync happen.
  • We can’t help you without steps to reproduce. See the linked page for examples.
  • We also need a Report ID after the problem occurs, as explained on that page.
  • Ok. I try this

    ID: 416206003


    1. Choose any folder visible in the Zotero app.
    2. Choose new item
    3. Add a manuscript and write "Test manus" in the title
    4. Add "xxx" in the Abstract field
    5. Sync manually
    6. Close the app
    7. Reopen it
    8. The manuscript is there, but the abstract field is empty.
  • This sounds like you're just not closing the Abstract field.

    This has nothing to do with syncing. Zotero is a local program and saves data locally regardless of whether you use syncing. But nothing is saved until the field closes, so if you quit the program with a field open, it won't be saved.
  • Thank you, I actually arrived at the same conclusion later today after some testing. But what is the best way of closing a field? Simply to do something else (open another field, for example)?
  • Just click outside of it — e.g., click on the item in the middle pane, or most parts of the background of the item pane — or press Return on your keyboard.
Sign In or Register to comment.