Zotero desktop, doesn't see data folder, which is just there where it always was.

Hi,
I've just opened zotero after not using for some weeks (months?) and I got the error that zotero couldn't find the data folder. Previous location ~/Literature/Zotero. The previous location is in tact.
Pushing "locate" on the error dialogue box did nothing. If I start zotero anyway, then try to add the custom folder anyway in Preferences>Advanced>Data Directory location, the file browser in zotero only displays the "default" home folders (Desktop, Documents, Pictures, etc), but none of the dozen or so other directories I've added to Home. Making hidden files visible also only shows a couple of hidden folders (there are many). This is super strange.
Has anyone experienced this | know a solution?
  • edited 13 days ago
    If this is Linux, you're likely using a third-party package of Zotero that's sandboxed and doesn't have access to non-standard locations (like ~/Literature/Zotero). You'd have to override that or switch back to the default data directory location.

    We can only provide support for the official tarball from this site (or the minimally repackaged deb based on the tarball), which isn't sandboxed.
  • I figured it was something like this...Linux, indeed. Zotero is installed via my distro's software utility, and was working fine before. Some update must have gotten to it. The GUI also looks funny – guess I have to restyle it too.

    For anyone facing similar issues, I needed to run

    ~$ flatpak override --user --filesystem=~/Literature/Zotero org.zotero.Zotero

    and then point zotero back to my ~/Literature/Zotero folder in the Preferences.

    Thanks for the tip. dstillman!
Sign In or Register to comment.