Save to Zotero (PubMed) problem

Hi,
The "Save to Zotero (PubMed)" button does not always work properly in Pubmed.
For instance, on this result page from a search in Pubmed
https://pubmed.ncbi.nlm.nih.gov/?term=health+science+library&sort=date&size=20
Only 8 of the 20 references are "Save to Zotero"...
  • Are you clicking the save-multiple (folder) icon and receiving only 8?

    I tested your link and only was able to import 5 using that method.

    I've given up on that method because PubMed's rate-limiting is altogether too restrictive.

    This works well:
    Select the PubMed items wirh the PubMed tick-boxes.
    Click the Send To button
    Select Citation Manager
    click save file
    A .nbib file will be saved to your computer
    Using Zotero's File > Import select the file you downloaded.
    Say yes to the default options in the next two Zotero boxes and then click Done.

    The records will be imported into a new collection.

    This is easy and very quick. I successfully import 120-150 PubMed records using this process every day.



  • FWIW, this imports 20 items for me fine -- was this after importing from other searches, too? I can't see Pubmed doing rate limiting after 20 requests.
  • It's not 20 requests, is it? It looks like we make a single request with all the ids. So what's even happening here? Is PubMed just not returning data for all results in the EFetch query? They say "several hundred records can be downloaded using one EFetch request".
  • edited 18 days ago
    Just now, this evening, I went to the OP's linked PubMed search page. I used the Zotero folder icon. When the Zotero box appeared I clicked the select all button. Tonight I downloaded 16 items of the 20. Early this afternoon my search and fetch using the folder Zotero icon was the first time in many months I've used the folder icon to import PubMed items into Zotero. [[As I've said before my searches with PubMed return several hundred results and I use the PubMed tick-boxes to select the usable items for my purposes as even with 50/page my searches result in many pages of items. Before the new PubMed interface, I downloaded the items in PubMed XML and used my proprietary parser to capture PubMed records and massage them before importing to my non-Zotero database. With the new PubMed database I now export in nbib format and successfully import into Zotero. FWIW some time ago I had tried to save as PMIDs and import them into Zotero but was rate-limited :
    https://forums.zotero.org/discussion/86806/pmid-via-magic-wand-rate-limited-something-else#latest ]]

    I can try to work with you on this issue. I find it very odd that some folks have a problem that you cannot reproduce. This sort of thing fascinates me. Clearly, I have no idea how Zotero fetches records from the NLM.
  • edited 15 days ago
    @dstillman
    I tried to reproduce the problem mentioned above after I did my usual search and retrieval. My initial PubMed search results produced 980 records. I show these in a series of 50 items/pages. After exporting and importing the resulting nbib file of 147 items; I tried to see how many of the last page of items I could import using the browser toolbar Zotero folder icon. To my surprise instead of the 30 items I expected I encountered all 980 records with all of the 147 items I had ticked on the pubmed site already pre-ticked in Zotero. I tried to import these 147 items and all records appeared in the selected Zotero collection. This was the first time I tried to import items that I had selected in PubMed via the save-to-Zotero folder icon. My problem above was encountered when I had a page of fewer than 50 items none of which I had ticked on the PubMed site. By the way, I tried to reproduce the problem I encountered 3 days ago (importing unticked PubMed records by ticking Select All in Zotero) and all records were imported. Perhaps this was an intermittent PubMed site problem.

    This is __wonderful__. I didn't realize this was possible from reading the Zotero documentation.
Sign In or Register to comment.