Capitalised ibid

Hi, in a style I am currently designing (in the visual editor) everything is working fine, except that the term for ibid (German: ebenda) is capitalised even when there is a prefix in the citation. How can I make it capitalise only when it is the beginning of the citation?

(In another style it seems to be capitalised only when using a locator, and I cannot find the difference to the one without in the Visual editor. There must be...)
  • edited 19 days ago
    Check if text-case "capitalize-first" is set anywhere. Could be on the ibid term or the overlaying macro. (easier to just search in the code by switching over to the code editor).

    Also, the VisualEditor has some little hickups like that. Always worth downloading the style and trying it within Word or within the Style editor in Zotero.
  • I will search. To try this it is necessary to download the style anyway, as far as I can see, since there is no way to include prefixes in the example citations.
  • I find three instances of "capitalize-first", two in the Macro "volume-for-books" and one in the macro "pages". None of these should have anything to do with the ibid term, as far as I can see.

    And this is true for both styles I checked, one of which is working for ibid without locator.

    I am lost. This must be due to an option not accessible with the visual editor, but where?
  • I think the problem has to do with the colon preceding the term. The citation should read:
    Vgl. ebenda.

    I have set it to
    How can the colon be ignored? The text-case is currently set to "sentence", but it wasn't working either when it was set to the blank entry.
  • Can you share your code on pastebin/hastebin?
  • I have no idea how to do this.
  • Leaving out the colon after "Vgl" does not change anything, still capitalised.
  • edited 19 days ago
    Go hastebin.com, paste your code there, click on Save. Share the URL in the addressbar here. ;)
    (Also, you can edit posts here by hovering over the post and clicking on the wheel on the top right)
  • remove the sentence case from lines 261 and 268. Not needed as Word will automatically capitalise as needed. With "Vgl." in prefix it then prints it out correctly for me like: "Vgl. ebenda."
  • Really? I added these afterwards, they weren't there before, and it made no difference, but I will try again and let you know.

    Can you explain how Word will capitalise anything? I thought this was all part of Zotero's formatting, if Word is playing a part in this, perhaps there is setting in Word I should look at?
  • Ok, now it does work, at least if the prefix is only "Vgl.". It does not work if there is a longer sentence in the field, which ends with "vgl.", Zotero or Word seems to interpret that as the end of a sentence now.

    I can work around this, though, at least in this case.
  • Why would you put a long sentence in the prefix field?
  • Because there are several citations in the footnote, and a sentence linking them. I have now put that into the preceding item's suffix field, ended that with a comma, and put "vgl." into the prefix. That works.

    I find that if I put separate citations into one footnote it becomes difficult to access them through Zotero.
Sign In or Register to comment.