Not adding citation to bibliography

Hi, I've changed to Zotero from Endnote but having issues with citations in-text not appearing in the bibliography. It is taking a ridiculous amount of time to go backward and forwards checking each one is appearing.
I have 'created bibliography' on each missing element, but this gets wiped again whenever a new entry is made again onto the bibliography.
I don't want to go back to Endnote if possible but this is really frustrating!
  • This sounds potentially like a misunderstanding.

    What do you mean by "Create Bibliography"? Do you mean that you're manually pasting bibliography entries into the bibliography? Don't do that — that's 100% wrong and won't work.

    When you add a bibliography with "Add/Edit Bibliography", the resulting bibliography will just be a representation of any active Zotero citations in the document. If something isn't appearing, it's not an active citation, which could happen if you're saving the document in the wrong format. See Existing Citations Not Detected for how to check if a citation is still active and for the things you could be doing to cause it to be flattened into plain text.
  • Thank you for your guidance.

    I have taken the following steps:
    1. Deleted the reference from my library, re-uploaded it.
    2. Opened a new document, saved as .docx
    3. Added new citation to new document.
    4. Still only gives me the citation without the full bibliography details.

    What could I try next? Many thanks.
  • Could you explain exactly what you’re doing in the new document, step by step, and what’s happening, with full examples?
  • I want to reference a source in the document, so have typed my sentence then pressed 'add/edit citation'

    As it is a new document, a box comes up asking for document preferences. Citation style is already highlighted (University of Leeds - Harvard). Source citations is already filled (fields). Automatically update citations is ticked. I press 'ok'

    The red zotero box comes up, I enter the source and select the corresponding citation from the list underneath. Press enter.

    Citation appears in text, presented as per citation style. There is no corresponding bibliography text.
  • You need to actually add the bibliograph (once only, it will auto-update then as you add more citations) in the document.
    Move the cursor where you want it, then, still in the Zotero Word toolbar, click "Add/Edit Bibliography"
Sign In or Register to comment.